Specify which version of kangaroo to use

Hey there

I was wondering, but didn’t find an answer to this:
Can I specify which version to use for an included add-on like Kangaroo?
It is possible for packages installed with the package-manager, however Kangaroo comes preinstalled.

for context, I was using shapediver, which does not yet support Kangaroo 2.5.3, only 2.5.2. However I do not necessarily need version 2.5.3 for my project.

Thanks for any assistance!

When saving a Grasshopper model, the file contains a list of plugins being used by the model, including the plugins’ version number. This corresponds to the version number of the plugin installed. A few possibilities to solve the challenge you are facing:

  • Use the Rhino 7 backend system (assuming you have a paid ShapeDiver account). Version 2.5.3 of Kangaroo is installed there. You can find a list of available plugins on this settings page of your ShapeDiver account.
  • Downgrade your locally installed Kangaroo to 2.5.2
  • Hack: Save the model using Grasshopper’s xml file format. Edit the file using a text editor, and change the version number noted for Kangaroo.

Thank you for the suggestions.

I could not find any information on downgrading, neither through a Google search nor in the Rhino settings.

I did find references to packages in the XML, but Kangaroo was not among them, nor were any versions 2.5.3.

I tried changing the version of what I assume to be Grasshopper from 80 to 60, but apparently that is an invalid version.

    <item name="plugin_version" type_name="gh_version" type_code="80">

Do you have any guidance on how to learn more about downgrading or manipulating the XML?

Thank you!

I also tried adjusting the Major and Revision attributes, but to no avail.

You need to edit the version of Kangaroo, not the version of Grasshopper. You can do this with a quick search for all instances of the string 2.5.3 and replace those with 2.5.2:

If you cannot find them, please post a ghx file here so we can give it a look.

Thanks for the screen-shot, I now know what to look for.
funny enough I don’t even use kangaroo, which is likely why I didn’t find it in the first place.
I will later try to include kangaroo in the .ghx nonetheless, and see whether this would work as well.

Upgrading Shape-diver to Pro did help.