Space Mouse


#1

I currently have a 3DConnexion SpaceNavigator and when opening igs files in WIP6 it wll go right to “Creating Meshes” and will not let anything else happen until it finishes. Including shutting down the program other than Ctrl-Alt-Del. This didn’t happen in V5, so something changed in WIP6.

Is there any other space mouse out there that works with WIP6 and will not start meshing???


(Brian James) #2

Hi Gary,

I’m a user of this 3D connexion device too and can reproduce the issue with large igs files. I filed this bug report for future reference…
https://mcneel.myjetbrains.com/youtrack/issue/RH-38804

I also have filed a very similar issue in the past which is referenced in that report so hopefully the two of them can help the developers figure out what’s happening here and why. You need a really dense igs file to see it and usually those files are proprietary in my experience so I made a simple test procedure for the devs to reproduce it.

Something I noticed while testing this was that the igs import in the v6 WIP is 20x faster than in v5! So I found it still faster than v5 to just wait for the render mesh creation in the v6 WIP when the 3D connexion plugin is enabled… for what it’s worth.

FYI @stevebaer @dale @Markus


#3

Thanks for the comments and support with this issue. WIP6 has several things that are far superior to V5, but if I can’t use the tools that make my workflow faster I’m going backward.

Regards,

Goth02 2 Sm eMail

The Core - Gary R Fulkerson, CEO - 10185 Elizabeth Lake Road, White Lake, MI 48386 - 248 819 8052 - gary.core@comcast.net


#4

I was the one who had previously reported the problem (RH-22985).

To get the meshing to stop in wireframe mode, disable Rotation Center - Auto in the 3Dconnexion menu (_SpaceMouse _Popup__Menu).

Thank you,
Steve


(Brian James) #5

Thanks! I’ll add this to the bug reports to help the developers.


#6

Yeah, I read this and could not figure out how or where to do this with my mouse. There are very few controls available in its set-up app, and there is nothing in any menu that has “Rotation Center” in it.

Can this guy do a step-by-step of how to disable the Rotation Center?

Regards,

Goth02 2 Sm eMail

The Core - Gary R Fulkerson, CEO - 10185 Elizabeth Lake Road, White Lake, MI 48386 - 248 819 8052 - gary.core@comcast.net


(Brian James) #7

The settings menu button on the 3D connexion navigator has the ‘auto’ setting in the ‘rotation center’ fly out.


#8

None of what you’re showing exists with my mouse. I have two options, one is the apps menu and the other is the menu button that is not what you are showing.

Apps options:

Screenshot (1)

Menu button on the mouse:

3D

Regards,

Goth02 2 Sm eMail

The Core - Gary R Fulkerson, CEO - 10185 Elizabeth Lake Road, White Lake, MI 48386 - 248 819 8052 - gary.core@comcast.net


(Brian James) #9

Are you clicking the settings/menu button on the navigator when in a Rhino viewport? This brings up the menu I showed in the last screenshot here. If that’s not working for you, check that the 3D connexion plugin is enabled in Options>Plugins within Rhino.


#10

This is what I get when clicking the menu button:

Screenshot (2)

This is what is in Plug-Ins:

Regards,

Goth02 2 Sm eMail

The Core - Gary R Fulkerson, CEO - 10185 Elizabeth Lake Road, White Lake, MI 48386 - 248 819 8052 - gary.core@comcast.net


(Brian James) #11

I’m not sure why you’re not getting the same settings menu. In the All plugins list, check the Properties of the 3D connexion plugin… This is what I get…


I used the Rhino WIP too as I see that’s the version you’re running.


#12

I didn’t have “All Plug-Ins” selected. This is what I have. I checked the website and I have the latest version available. What do I do from here?

S

Regards,

Goth02 2 Sm eMail

The Core - Gary R Fulkerson, CEO - 10185 Elizabeth Lake Road, White Lake, MI 48386 - 248 819 8052 - gary.core@comcast.net


(Brian James) #13

Have you tried running the SpaceMouse command and then clicking on “Popup_Menu” in the command line options? This brings up the same settings menu for me. If that doesn’t work either, I’d try emailing 3D Connexion using the email in the Plugin Properties to see if they know why you can’t see the popup menu for the navigator in Rhino.


#14

I think the easiest way to solve this is for you to consider me an idiot about computer commands and give me step by step instruction like you would give a 90 year old man that’s never touched a computer before.

Example of my being an idiot is I don’t really know what you want me to do when you say to run the SpaceMouse command. If I right click on the Window logo in the lower left corner of my screen I can select “Run”, that’s what I tried with these instructions and I get the warning the Windows cannot find “SpaceMouse”. Other than thius I don’t know what you want me to do… I just saying…

Regards,

Goth02 2 Sm eMail

The Core - Gary R Fulkerson, CEO - 10185 Elizabeth Lake Road, White Lake, MI 48386 - 248 819 8052 - gary.core@comcast.net


(Brian James) #15

Try this…
1- Open Rhino
2- Type “SpaceMouse” and press Enter
3- Type the letter “P” and press Enter

This should display the 3D Connexion Navigator’s pop up menu with the rotation center controls.


#16

That worked… I turned off “Auto” if that was what I was supposed to do. Thank you for your help.

Regards,

Goth02 2 Sm eMail

The Core - Gary R Fulkerson, CEO - 10185 Elizabeth Lake Road, White Lake, MI 48386 - 248 819 8052 - gary.core@comcast.net


#17

I opened a few files that before would go right into creating meshes, and they didn’t do so any more. It appears that you helped fix the issue. I’ll contact 3DConnexion and inform them of the fix.

Regards,

Goth02 2 Sm eMail

The Core - Gary R Fulkerson, CEO - 10185 Elizabeth Lake Road, White Lake, MI 48386 - 248 819 8052 - gary.core@comcast.net


#18

I stated to use the _SpaceMouse command because I also no longer see the popup menu in either V5 or V6. Also, the command macros in Rhino Options - 3Dconnexion Buttons no longer work. What version of the 3DxWare driver are you using? I’m using the latest, 10.4.10.


#19

3DxWare64_v10-4-10_r2558 is the latest version for the mouse. Brian gave me the instructions below to get to the menus:

https://discourse.mcneel.com/u/brianj BrianJ McNeel
May 8

Try this…
1- Open Rhino
2- Type “SpaceMouse” and press Enter (in the Command: line)
3- Type the letter “P” and press Enter (in the Command: line)

This should display the 3D Connexion Navigator’s pop up menu with the rotation center controls.

Regards,

Goth02 2 Sm eMail

The Core - Gary R Fulkerson, CEO - 10185 Elizabeth Lake Road, White Lake, MI 48386 - 248 819 8052 - gary.core@comcast.net


(Brian James) #20

I don’t think I’m running that type of driver. I don’t have a 3dxWare app on the system either.

This is my driver info from the device manager and the Rhino plugin.