Space mouse not working with Rhino6 sp10


(IVELIN PEYCHEV) #21

You’re wrong, as I have used every SP since Rhino 6 was released on this machine and up until SP10 I had no problems with the space mouse.

@Rhino_Bulgaria has a point. @McNeel simply has to maintain support for old models (although my space mouse is not old at all) Also as said numerous times in this thread, I have no problem with other software (3DEXPERIENCE / CATIA, DraftSight)

@dale, is there a way to acquire old SP installers? I’ll try the above mentioned method. As I think I deleted SP9 installation and I have upgraded all my machines to SP10.


(IVELIN PEYCHEV) #22

The update of the software and the driver solved the issue.


(Marc Gibeault) #23

It’s all very sad that they render obsolete their devices like that. There’s no good reason my SpacePilot should stop working, even if it’s old… In fact, it works flawlessly in SolidWorks right now with this software/firmware:
image


(Dale Fugier) #24

@ivelin.peychev,

I’ve sent you a link to SR9. However, the code behind the 3dxRhino plug-in, included with Rhino, has not changed since May 11. But rolling back to a prior SR is worth a try.

– Dale


#25

had the same problem after upgrading V6 from sr9 to sr11.
upgrading 3dxware from v10-4-9_r2527 to v10-5-12_r2890 solved the problem for me too.

before installing the new release i removed the old one via control panel, which let rhino recognize my space mouse. also when working at other computers (university) without 3dxware installed, i simply plug the spacemouse and it´s immediately recognized in rhino. adjusting via rhino´s spacemouse popup-menu is the same as in 3dxware.
so if one has no other 3d-applicatios besides rhino installed, i would recommend running the spacemouse without 3dxware.