Sorting Meshes Fails by Face counts, but Succeeds By Area - Bug? [Solved]

So I created some meshes and want to sourt out the biggest. But for some reason the Sort component complains about different numbers of Key and Values (159 in both cases) if I sort by Faces (or any other count based on the Deconstruct Mesh component), which isn’t true.

If I use Area (also 159 Keys) as the sort Key then it works.

Fig 2. The error message (for Face count)

Not true. Both Keys and Values are 159. Must be a bug.

I recall doing this often with R5 and then I had no problem with this.

// Rolf

Can you attach your definition? (internalize rhino data, if needed)
Also, you should turn on fancy wires.

A simplified example :

debug_mesh_sort.ghx (3.3 MB)

Flattening & Grafting (which I tried, of course) didn’t do any good.

Edit: Ops, forgot the counter when reconstructing the failing stuff.

// Rolf

Flatten the output of list component.

Thanks. I was very sure of that I had tried that, but obviously I hadn’t!

// Rolf