Some files with pointclouds lock/freeze PC without any error anywhere

Isolated just one pointcloud that freezes PC. Had to zip to attach here. It’s only 56MB unzipped.
The original pointcloud is a .PTS file created by FARO Scene.

To repeat the freeze - open the file in R6 and start rotating it with 3D Mouse.

Does this have anything to do with it? Why is it sending me to the home page?

image

002.7z (14.4 MB)

Rhino 6 SR15 2019-5-28 (Rhino 6, 6.15.19148.13161, Git hash:master @ ae191a06e4addc9964c3f4231a3312f38d4153d0)
License type: Commercial, build 2019-05-28
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: ENG10

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1080 (NVidia) Memory: 8GB, Driver date: 10-2-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 416.16

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-2-2018
Driver Version: 25.21.14.1616
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Don’t have a 3D mouse, but I opened your file - it has only one parallel viewport which I tried panning, no problem. I ran 4View twice to reset the viewports to default, then I tried orbiting the perspective viewport (RMB) - no problem here… Don’t know if the problem is being caused by the 3D mouse driver?

It doesn’t freeze in R5.

We don’t use 4Views as most of the time nothing in the model is parallel to them.

Doesn’t freeze in V6 here either… 3D mouse driver may be different from V5 to V6. Does it freeze if you tumble a non-parallel view with the RMB?

  1. Open file in R6 (R6 starts the 3D mouse driver even if it’s been stopped already)
  2. Stop the 3D mouse driver image
  3. Pan with MMB
  4. PC freezes randomly within 5-60 minutes.
    First Rhino freezes, then mouse cursor after a random amount of time.

This is what windows event log has to say about it:

It works fine if there’s no pointclouds in the model.

Well, I can’t reproduce the situation here in any case.

Note the event log still blames the 3D mouse driver module somehow…
image

I think @stevebaer is the person who has been working with point cloud display.

Hey, I don’t disagree. :wink:

The 3D mouse driver is not written by McNeel, I believe, so maybe another avenue to explore is to contact their support as well. If you go into Options>Plug-ins and right click on the 3Dconnexion item and choose Properties, you will have all the contact addresses including a phone number (Germany)…

Try disabling the 3d mouse in Rhino’s plug-in manager and restart Rhino. Then import your point cloud. This will help determine where the problem is occurring so we can figure out what to do next.



Same type of freeze.

HGello - is the 3dx connected when this happens? If so, does it make any difference if you unplug it as well as disable the plug-in?

-Pascal

No difference. Same freeze. I’ve been told that 3dconnexxion got the whole new driver package. I’m gonna try uninstalling the current one and installing that one tomorrow. No more time to waste on troubleshooting this today.

I REALLY NEED somebody to look into it. It’s 100% R6 issue, 'cause R5 works just fine.
I can upload the files, just need to know who to tag in it.

The reproduction of the freeze is simple:

  1. Open the model file
  2. Drag & drop + Attach the pointcloud file
  3. Draw lines or polylines
    ANY PC will freeze within 10 seconds to a minute.

I’ve been working with a couple big pointclouds (1-3 gig) this week with no issues. My workflow is .e57 into a .3dm, attach file into working file. No issues.

Same here. It doesn’t happen on every pointcloud. But the ones it does happen on are impossible to work with in R6. I’d say one out of 10. We’re forced to revert to R5.