Some Displaymodes are giving me unknown command

At some point, the displaymodes Technical, artistic, pen, raytrace neon stop working. If I try to use them, I get unknow command on the prompt. All the other ones work fine. How do I get them back? I am on rhino 5SR11 64

Thanks in advance.


Hi Jaime - try: In Options > View >Display modes, select and delete these modes, and then restart Rhino - has it replaced the modes? Do they work?


There were no changes. Still unknown command.

I am running the latest version btw 2/5/15

Hi Jaime - are the display modes available in Options > View > Display modes? Do they show up on the viewport context menus? What is the exact method you are using to activate the modes- is it a button, command line, menu item, your own macro?



I am just trying to change them on the left upper corner of the viewport. They do show on all the windows,

They also show up on the options>view>displays. Not sure if the color is a clue of why they are disable.

I get all the options when I highlight them there.

I see - can you please disable TSplines in Options >Plug-ins page and then restart Rhino and see if there is any difference?



If you go to Other Settings under the misbehaving modes, are “Include in View’s display mode menu” and “Include in Shade command modes” checked?

I disabled Tsplines and the results are the same. (Unknown command)

Sam: Options are checked on all the unseen displays. Thanks.

And restarted Rhino, correct? Just making sure…

thanks, -Pascal

Yes. Did it a couple of times.

Is Neon among the plug-ins listed in Options > Plug-ins page?(Show all plugins) Is it enabled? If it is not there, please locate the rhp file and drag and drop it onto Rhino and see how that works for that display mode at least.


Neon was installed and enabled. I uninstalled, downloaded it installed it again and it shows as unknown command.

OK, thanks- I am somewhat grasping at straws here- are these missing modes all set to Defaults in Options > View > Display modes? There will be blue text in the settings if not.

@jeff, @andy, do you have an idea what could be causing this? Neon and the default ‘Technical’ based display modes have stopped working.


They are all set to default. Including the fresh install for neon.

Another grasp at a straw, what happens when you make a copy of one of the misbehaving modes? Does the copy show up / work? If still no, on the copy, under Other Settings try changing the pipeline from Technical2D to OpenGL.

Nope - I have no idea what’s going on here.

Running in Safe mode?
Intel graphics chip?

The copy shows up. But still gives an error. I did change to Open GL.
No matter what changes or duplicates I made, still gives me the Unknown command. I am not running safe mode, and I am using an Nvidia Quadro FX card.
I just install the simple bright display mode. It shows on my tools/view display, and on my viewport but if I selected the error shows up.

The graphics chip being used would have nothing to do with this. This is not a GPU or display pipeline issue.

We are seeing this from another user on another support forum (unless you’re the same user, dunno)… But apparently it has something to do with his user profile. If he logs into his computer as a different user, then everything seems to work, so it’s looking more like some kind of permissions and/or profile issue.

Do you have any custom display modes created?