Solver Error: "carat.exe not found"

Hello :wave:

For some reason The IGA Solver Component is giving me the error: carat.exe not found!

Error:

CaratNotFound

carat.exe path

The carat executable is in the plugin folder:

I’m running Rhino 8 but get the same error in Rhino 7.

Any ideas on how to fix this? Thanks so much! :pray:

Did you move the files after installing Kiwi?

@anna_kiwi3d I didn’t move any files. carat.exe is in the plug-in folder where the RHI installs it by default.

My first thought was that it might be our office Software Restriction Policy but I added the .exe to the allowable list and still have the issue.

It’s almost like the component can’t find the path for the executable.

@anna_kiwi3d Just to confirm… the correct location for the carat.exe executable is AppData\Roaming\McNeel\Rhinoceros\8.0\Plug-ins\TeDAsharp... as shown above?

Yes, seems correct, if you used the installer. If you did it manually via Rhino Pluginmanager, it is the initial folder. In general, carat.exe has to be next to the TedaSharp_050.rhp file.

Do you have any special characters in the path of the GH file? Spaces were also a problem once. So you could also check this.

Hi @anna_kiwi3d sorry it’s been quite a while and I never answered your previous question regarding special characters in the path. I’m still unable to run Kiwi3d because carat.exe isn’t found.

There are no special characters, I’m simply trying to run the 5pt sail .gh example which doesn’t have any spaces in the file path:

"C:\Users\bfrederick\Desktop\Kiwi3d_Tut_FoFi_5ptSail\Kiwi3d_Tut_FoFi_5ptSail.gh"

Are you seeing this issue from other users?

@anna_kiwi3d I was able to resolve the issue by moving copying the files. The current rhi puts the contents into a child folder under the plugin folder 0.1.0.0 , by moving copying these one directory up to: C:\Users\username\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\TeDAsharp (ce983e9d-72de-4a79-8832-7c374e6e26de)
the issue was resolved.

Hey Bob, glad you got yours to work.
My folder looks like this after install:

If I move the files up to TeDAsharp, GH prompts that the plug-in is not installed.
If I keep them in 0.1.0.0, then carat.exe is not found.

Any tricks anyone?

@xy236 I should have mentioned I copied the files up one directory. I didn’t move them :slight_smile: Hopefully that works for you.