(Solved) V-ray freezes for NO REASON

@matt_newberg

This is not good.

“Interface-slow-and-freezes-often” seems an old topic in V-ray Fourm, but why no fix?

How to create the problem

  • Create a geometry in Rhinoceros (In my case, a sphere. Unite=feet)
  • Open V-ray material window
  • Create a V-ray material

Shown in the Demo.

The problem didn’t happen immediately, after a couple minutes, it freezes. I neither assign material to the object, nor changing any parameters.

Update:

Demo

When V-ray parameter cannot be edited (shown in the picture,) I have to close Rhinoceros and restart again.

I posted another one yesterday here.


Other Problems !

V-Ray RT view mode in viewport doesn’t work. It shows wireframe-ish look.

Material doesn’t update (Live update was checked)

Renderer= V-RAY

Maxwell crashes when apply Hight Rez HDRI image.

V-ray got the problems that cannot produce work at all.

My question is users go which direction?

The same thing as described in your screencapped post happens to me all the time in Vray. It’s usually the Vray Options window that freezes up and will not accept any mouse clicks, meanwhile Rhino is still running fine. It is like a modal popup dialog has focus, but there isn’t one - very frustrating. Only solution is to close that Rhino instance.

I’m not positive, but it has appeared sometimes to coincide with Rhino autosaves for me, have you noticed that?

Have you heard these reports before, or have any idea what’s causing this, @matt_newberg?

Running Rhino 5 SR 11 x64 on Win7 with Vray 2.00.25251

1 Like

I understand this as the developers haven’t tracked this behavior…hopefully.
If the developers pretend that this is not a big issue or delay to fix. I would not recommend V-ray for Rhinoceros to anyone, period.

Certain bugs users can ignore, but some others not. Crashing/freezing behaviors indicate that the software is not mature.
Issues have addressed in V-ray forum, you can find more info there. @gregb

Thankfully, I only use V-ray because of one feature. The toon mapping.

@KevJin,

At Chaosgroup we take any bugs related to crashing / freezing very seriously. We have recently released an update that resolves all the issues we have found related to that. We do not know what your 3dm / model / computer has for specs and how it might affect freezes, so we cannot say we have resolved all issues, but we are pretty happy with the latest builds. You should of received an email from Chaosgroup about a new SR3 build as mentioned here: New V-Ray Service Release (#3)

In this latest build if you are able to duplicate freezes / crashes / hangs feel free to send the file, with version number, and computer specs to: vrayrhino@chaosgroup.com or support@chaosgroup.com, and we will look into it further.

Matthew Newberg
V - Ray For Rhino Developer

1 Like

@matt_newberg
Thanks matt, I downloaded it after seeing Dave post.

I did a quick test yesterday.
The Materials I used updated in real time.
I can feel the difference.

Should we delete this post??

@KevJin

The post is fine.

Sorry for the delay. Normally we respond faster, but we were busy working out the details of the SR.

1 Like

You can edit the message title and add “(resolved)” so other readers will see there is a fix in the thread.

@John_Brock

It would be nice there is a solved button somewhere. The discourse can work like this.

Using different tabs to categorize answered and unanswered Qs.

It would but I don’t think Discourse is quite that fancy.
Editing the message title is easy enough. I think you can edit the ones you created.
If not I can make the addition.

I just found out about the new update by chance while browsing the forum. It’s July 11 and I didn’t get any communication from Chaos Group making me aware of the update as a registered user.
Any idea why?

You should subscribe to their newsletter. I don’t think they notify people any other way (that I remember!)

Updated to 25962 but option editor window is still freezing.

This worked for me (from V-ray Pop-up window freezes)

Search for “vrayforrhino.ini” in: C:\ProgramData\ASGVIS (program data is a hidden folder)
open It with wordpad, scroll down until you find

[Licensing]
gui_timeout_minutes=5

Disable gui_timeout_minutes by changing its value to -1

1 Like

I’m very excited about his post, could end endless moments of frustration.

It still happens to me in the demo version. I would expect that you want the demo version to run smoothly.
Any ideas?

I have installed the latest Rhino (5.13) and Vray (20026563 ADV), but the same issue happens to me. Every time I try to open Material Editor it freezes and Rhino gets super slow. Tried to search for the file “vrayforrhino.ini”, but it does not seem to exist in the latest release (?).

Need advice!

This is where mine is located.

Surely this has got to be the worst default setting in the history of software…

Ah. Thanks! Found it.
But here gui_timeout_minutes are already set to -1.

What then?