[SOLVED] Rhino 6 crash on startup (USB-C dock related)

Hello.

I’m an IT Tech and I was performing a full PC reinstall for my client due to issues not related to Rhino. After installing Rhino everything went fine - I was able to hook up owner’s rhino account and application started without problems. I got back to client’s desk, hooked up USB-C dock and started showing the client all the apps and modifications done. Imagine my surprise when Rhino had crashed right after double click. No welcome screen or even app screen, just crash report window.

I did some troubleshooting and digging through forums and was able to find similar problems and few posts steered me in the right direction. I was able to determine that the issue presents itself when there is USB-C dock with monitor connected to the laptop.

More on the issue itself. Laptop is Lenovo Yoga 730-15IKB. It is equipped with i5-8250U, integrated Intel UHD 620 GPU and dedicated GTX 1050 4GB GPU. Not a typical workstation, but my client uses it for checking the designs his employees had made and it’s perfectly capable for that task.
Issue started presenting itself on the latest drivers and software possible:

  • Rhino 6 SR28
  • NVIDIA GPU driver: 451.77 Studio Driver (also tried latest Game Ready driver)
  • Intel GPU driver: 27.20.100.8581
  • DisplayLink (USB-C dock) driver: 9.4 M0
  • Windows 10 x64 2004 build (latest updates installed)
  • .NET Framework and VC++ Redistributables installed and updated.

Both Windows and Rhino are using Polish locale.

After some testing:

  • USB-C dock connected, Rhino running on NVIDIA GPU - crash
  • USB-C dock connected, Rhino running on Intel GPU - works
  • USB-C dock disconnected, Rhino running on NVIDIA GPU - works
  • USB-C dock disconnected, Rhino running on Intel GPU - works
  • USB-C dock disconnected, starting Rhino running on NVIDIA GPU then connecting USB-C dock - works
  • Turning off Intel GPU in Device Manager - almost crashed the system since Intel chip is needed for passing video signal through USB-C for both Intel and NVIDIA GPUs.

Before the reinstallation, with old drivers (early to mid 2019) it was working well with USB-C dock connected and running on NVIDIA GPU.

I was able to save the crash dump file and attached it to this post. I’ve also sent it through crash report app with client’s e-mail address which I don’t want to add to this public post.

Currently as a workaround I’ve deactivated NVIDIA’s GPU in UEFI hoping to find a solution that won’t require going back to old Intel drivers (they were problematic in some other applications). I don’t have direct access to the machine but my client is aware of the situation and allowed me to remote in when the PC is idle to do some more testing if required.

I will be grateful for all the help and suggestions. Can be technical ones, I don’t mind.

RhinoCrashDump.7z (4.2 MB)

See if this is the issue:
https://wiki.mcneel.com/rhino/faq/slow-rhino

Hi @Corey,

I had a look at the dump file and from what I can tell the crash occurred in ig9icd64.dll which, I believe, is included with the Intel graphics chip drivers.

– Dale

You’re running the “BETA” Windows driver.
You might try the released driver as a test:

Hey guys,

Thanks so much for suggestions - I will try them tomorrow. I’m aware of those drivers having BETA status, but I’ve checked both changelogs before installing them. Still, I will try downgrading to latest stable ones.

Thanks Dale for analyzing dump file. ig9icd64.dll is in fact part of Intel graphic suite and proved to be the cause of OpenGL problems for people in other applications.

Will check the driver tomorrow and update the thread.

So, update as promised.

Issue was fixed by… connecting monitor to USB-C dock with HDMI instead of DP cable…

Post from John Brock has been helpful, because in it before finding that audio dll might be the culprit people had discussed DP and HDMI cables. I figured that since I had some problems with DP protocol in the past and Dale Fugier found an Intel driver problem in the crash dump file, I will give it a shot.

And it worked. Now Rhino starts on NVIDIA GPU and with connected USB-C dock and monitor (HDMI). I still left the beta driver in the system.

Conclusion: latest Intel drivers appear to have problems with proper DP protocol handling and recognizing monitors connected to USB-C dock. Use HDMI connection on your docking station instead while waiting for fix in the drivers.

Once again thank you for your help with this issue.

2 Likes