Solved: Index out of range

Created my first Hops-script.

Is there a way to trouble shoot were the error comes from (index out of range)?

If I simply copy my hops script and connect the wires, it works as intended.

Or has it something to do with the rhino compute server that reports Max concurrent requests = -1


This is the different results I get.
The lower part is the intended result,
the upper part shows the output when doing the same trough hops.

I should probably start with something simpler, the Hello world hops worked great.

But if someone has some input of what might be wrong, please let me know.

Attaching the gh-file with internalised geometry
hop_example.gh (36.3 KB)

It’s List Item that doesn’t work for med through hops.

I’m taking the first item from every branch, but when doing it through hops I guess it takes the first 3 items from the first branch.

listItem

ListItem.gh (2.8 KB)

Hej Lars -

You need to allow more than 1 for the “At most” setting:
image

=>

image

Note: using a “RH_OUT” group is the old way of working with Hops. You can use the Context Bake component.
image

-wim

1 Like

Thank you Wim.

It’s been a bit confusing reading old and new threads and trying to understand how it actually works now.