(SOLVED)Help! Can't load Xnurbs in Rhino winV6. Was ok just yesterday

@XNurbs

From today, can’t load Xnurbs in rhino.

Tried reinstalling the plugin and says successful, but just won’t load after reloading app.

Rebooting PC also not working.

Also checked to see if virtual machine related things are off, and there set off.
Hyper-V and Bios related as well.
Still not loading.

There was a Windows update that happened last night, might be that…
Any Help is appreciated!!!
(contacting xnurbs support via mail as well.)

Currently trying to “fix” Rhino V6 with installer → Still same, not loading.

System information as below:
Windows 10 Pro

22H2

19045.2486

Windows Feature Experience Pack 120.2212.4190.0

Rhino 6 SR35 2021-8-10 (Rhino 6, 6.35.21222.17001, Git hash:master @ 073ac7b225c67348731c6597127b9410126c3139)

License type: 商用版(commercial license), build 2021-08-10
Windows 10.0.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: MSI

Computer platform: LAPTOP - Plugged in [83% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 10-28-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3060 Laptop GPU (NVidia) Memory: 6GB, Driver date: 5-19-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.95
> Integrated acclerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-19-2022
Driver Version: 30.0.15.1295
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\HDRLightStudioTexture.rhp “HDRLightStudioTexture”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Something to check: The video drivers are somewhat old. Are they versions that Windows update installed over newer ones that you had been using before the Win update?

1 Like

I’ll see if updating device driver changes things.
Thanks for the info.

image
Updated driver, still not loading…

Solved by below steps:

Clicked the Install Button in Plugin settings in rhino and followed below steps.

Hi Toshiaki, I had a time once similar to what you are describing. It was a firewall blocking the plug in from loading. It loaded into the computer too a certain point then stopped and wouldn’t load into Rhino. It took it to our IT guy and he disabled something to let it load into the computer. —-Mark
Sorry didn’t e you had it solved.

1 Like