SOLVED: 3DConnexion Spacemouse Pro Wireless - drifting problem

I have been using the 3DConnexion Spacemouse Pro Wireless with fantastic results in Rhino for OS X and I ran into a big problem since a few days.

Since a few days when I am in the modeling view the space mouse is ever so slightly drifting.
The Spacemouse settings menu “calibrate” does not remedy the problem - the drift will simply move the view into another direction after calibrating but the actual drift will remain.

I did migrate to a new Mac a few weeks ago (via Mac OS X migration assistant) but kept the very same OS X Yosemite OS version and didn’t change anything about Rhino or the Spacemouse settings.

I also worked in Rhino after the migration without an issue.

I tried already:

  • reinstalling Rhino
  • reinstalling the Connexion driver and software
  • checking all settings up and down within the Connexion menu and Rhino

This is driving me nuts as you can imagine.

Any tip where to start to trouble shoot would be extremely helpful.

PS: I have to add: the drifting only occurs in Rhino - using the Connexion demo tools shows no drifting at all.

… And here out of nowhere the problem is solved (I do not know how).

As it may be helpful for others, here is what I did:

  • opened a 3D model with Rhino for Mac
  • immediately the view drifted ever so slightly
  • opened the Connexion menu system and hit the calibrate button several times
  • no change to the drifting
  • changed app focus from Rhino to web browser (Safari)
  • changed back to the Connexion menu
  • opened the Connexion tool menu and opened both the 3D demo view and the axis view
  • within both tools: no drifting at all
  • switched back to Rhino and the still open 3D model
  • still drifting !@#$% !!!
  • switched back to the web browser
  • connected the charging cable to the Spacemouse Pro wireless
  • switched back to Rhino

Drifting is solved - Rhino works as intended!

So the Wireless Spacemouse Pro only works when it’s plugged into the charger and therefore no longer wireless? :slight_smile:

No, the Wireless Spacemouse Pro works perfectly wireless (it worked flawlessly before the issue appeared).

I did not find the cause of the issue.

I will unplug the Spacemouse from it’s charging cable and see how it performs when I am back and see if the problem is truly solved (including wireless operation.

As the issue only appeared within Rhino I have really no idea where to start to troubleshoot the problem.

hi Menos
Are you using a MagicMouse by any chance?
This occasional Drifting happened to too me in the past, and more then several time. I believe it’s a 3DConnexion drives issue and not related to a specific model [i use the notebook model]
unplugging the USB and replugging it always resets this drifting error here.
One thing i tried was to disallow MagicMouse gestures in rhino options , i don’t recall encountering a drift since then.
With gestures on, both the 3d mouse and the Magic-mouse could manipulate the same view at the same time, or two different views at the same time, what seems to be an invitations for errors.


1 Like

Hey Akash, that’s a great tip!

I do use an Apple magic mouse and a trackpad (both type 1) and do use additionally an app called “bettertouchtool” which allows for a very high degree of individualization of input devices and keyboard shortcuts.

To report back after having charged the Spacemouse:

The issue has been completely cured and after unplugging the Spacemouse Pro wireless from it’s USB charging cable the drifting has not occurred again.

Akash might be onto something here and I keep the USB plug and unplug of the Spacemouse in mind.