Solid difference is not working after reducing mesh with Pufferfish

Hi there,

I’m trying to automate a short workflow through grasshopper.
Base is a topographic stl file I downloaded.
I want to take the top layer of the topography and give it a 1mm thickness.
As the stl file comes with a base of 5mm, I simply wanted to duplicate and move the copy by 1mm. After that, solid difference would do the job. This already works fine. However, as the stl consists of 40k polygons I wanted to reduce the mesh as the operation takes roughly 6mins…
after reducing the mesh solid difference seems not to work anymore.
I also tried to work with mesh difference and leave out the conversion to brep which also didn’t work.
Attached you will find a screenshot gh file and source stl.

I just figured out that if I reduce the mesh but keep resolution high (40k) the result is the same as in the first example. Reducing the resolution to e.g. 15k result is not processable anymore… (279.4 KB)

  1. I’d highly appreciate if anyone could tell me what I do wrong :raised_hands:
  2. I know there is another way doing this in a little cleaner manner with elk. Checked that option as well and it seems that my Mac does simply not want to support the plugin.

Thanks in advance to whoever has an idea on where I fail.


This doesn’t have anything to do with Pufferfish per say. That component is just running Rhino’s reduce mesh algo (same as doing it in rhino). My guess is the reduction is causing some mesh verts / faces to lay exactly on the geo you are trying to bool with which causes issues. In general Rhino is very picky with mesh Booleans. Try slightly enlarging one of the geometries.

1 Like