Sofistik Plugin not supported .... but not used

Hello all,

Very new to shapediver, tired to find some similar thread but couldnt. I tried uploading my first simple script, but ran into an error:

" Error

Library sof_gh_sofistik_rhino 2020.8.7711.23201 by may not be used yet."

The issue is that I am not using that plugin in my script (But i have it installed on my machine). Any idea on how to tackle this? I Have joined my scipt
Pipe (7.3 KB)

I can confirm that your definition seems to need the above plugin, as Grasshopper throws this error when I try to open it:

If you cannot find the specific component mentioned in this error (IO), you can try to copy all components from your definition and paste them into a new document. This has proven to solve the issue in the past.

Thanks Mathieu,

I’ve tried that already, but got the same error. I even tried that on a file that I downloaded from the Shapedivers examples, cleaned it and pasted just my geometry but got the same error message again. Tried also to open an example file, save it and close it, still the same error while it was working before i opened / saved it.

It seems that as soon as I save the file on my system, it gets “Corrupted” by this plugin. The obvious next step would be to try to uninstall the plugin, but would you have any other recommendation?

Btw, nice to talk with you again, we met a couple of years ago in a Rhino user meeting in Helsinki.

It seems that this plugin is indeed doing something unorthodox with your Grasshopper documents.
The only other workaround I can recommend is to save the file as .ghx and manually remove the chunk that is causing the issue. Open the .ghx with a text editor, look for sof_gh_sofistik_rhino and remove the part that is causing a problem (hopefully a small part). You can send me the .ghx version so i can have a look. That is cumbersome obviously, but the only way I see at the moment.

Nice talking to you again too!

1 Like

Yes, the Sofistik link is indeed mentioned in the GHALibraries (As is Pufferfish, Which i don’t use either but is probably supported by shapediver).

I am After a more stable and long-lasting solution than having to modify the .ghx every time.

This is probably not for this thread anymore but any idea how i can “Exclude” that plugin from belonging into the GHALibraries when not used into the definition? (That’s definitely a long shot, but we never know)
Pipe test.ghx (172.1 KB)

Thanks for the quick answer!!

Pufferfish is used in your definition (the Parameter Mesh Pipe component). In general, for a plugin to still appear in the ghx file in the absence of any components related to it is an irregular behaviour that could probably be prevented by the plugin developers.
On our side, we could be a little more lenient during model checking, and accept models even if the libary is listed, as long as no components make use of it, but that is a potential risk.
I will brainstorm a more convenient workaround with the team and get back to you.

Right, My bad about the meshpipe!

Thanks for investigating this on your side as well! In the meantime, ill probably uninstall the plugin, but mention to them about that. I agree that this is some irregular behaviors from this plugin!

As expected, uninstalling the plugin did the trick

I would recommend using the Pancake plugin which provides a “portability report”. It will list all 3rd party plugins someone else will need to run your definition and it can help you locate 3rd party components used in your definition. I don’t know if it would have helped in this case but I thought I’d mention it nonetheless.

1 Like

It seems Sofistik uses the component to store the version of GH interface. Both its width and height are zero, therefore not renderable on the canvas.

I will put a function into Pancake to remove hidden document objects.