So much laggy if a surface isocurves are many

if a surface has many isocurves, like more than 200, any operation (even zooming) become very laggy and slow under wireframe view mode. But if without showing wireframes, it is not laggy at all.

P.s. mesh models doesn’t have such preformence reduce like surface does.

Is any setting can improve Preformence for that?


Run SystemInfo and post the results here.