Snap to occluded with a point on surface - needs "tuneup"


#1

Version (6.1.18030.17371, 30-01-18) here.

In the attached file, with “Snap to occluded objects” enabled in Modeling Aids, draw a line between the two points (Point osnap). No problem.

Now, undo, disable snapping to occluded objects and try again. Point snap will no longer snap to the point on the surface from the side facing the camera. If you turn the view over, it will snap from the “underside”. The point on the surface has been placed with the “OnSurface” osnap…

SnapToSurfacePoint.3dm (58.6 KB)

Thanks, --Mitch


#2

This is useful command, but it needs refinement:

  1. There is no way to undo it.
  2. There is no way to know whether it is on or off.
  3. SnapToOccluded, SnapToLocked, and SnapToMeshes should be included in the Osnap control (panel).

(Pascal Golay) #3

Hi Mitch - Since the render mesh does the occluding, I guess this makes sense. Setting a very fine render mesh allows snapping to the point in both modes, here.

-Pascal


Problem snapping to points while in shaded view
#4

Hmm, do you think the average user will think so? Why would it snap on one side and not the other? Which “side” is the mesh on? Do you think they will know to change the mesh settings if they can’t snap? And to have to set a very fine mesh just to get that to work seems, well, a bit far to have to go…
(forgive my skepticism…)
–Mitch


(Pascal Golay) #5

Hi Mitch - yes, I meant to put ‘makes sense’ in quotes, but still… if a point is on a surface, is it occluded or not? Depends which side of the bed I get out of in the morning but right now, I guess I’d tend to not occluded. There would need to be some completely different mechanism for determining occludedness in such cases.

-Pascal


#6

Well, yeah, just thinking about it makes me feel rather occluded…


Why can't I pick this point?