Snap to nearest vertex is this possible?

Hi,
V5
trying to place a line start on corner of tractor cab but it could be seeing the console inside or far corner etc.
another example, trying to select wheel rim but it is also seeing inner face rim, then wheel arch, then cab, then seat, then same again on far side of tractor !
How do I get Osnap vertex to ignore all but the nearest part of a mesh ?

Cheers

Steve

Have you tried different shading modes?

I don’t know if this makes any difference for Meshes, but for Nurbs surfaces I recall that snap works “better” (more as expected) in shaded mode.

// Rolf

Hi Rolf,
I need to be working in Rendered mode as the texture displays only in that mode.

I wish the texture also displayed in shaded mode.
Is there a way of getting my .jpg also displaying in shaded mode ? It was created when the mesh prog (metashape) exported model as an .obj ?

Steve

I don’t know if this exists in Rhino 5, but in newer versions there is SetObjectDisplayMode.

Also, and again, I don’t know if it exists in Rhino 5, but in newer versions in Rhino settings you can uncheck to snap to occluded objects. That way you’ll be able to snap to only the visible vertices in Rendered mode.

CullControlPolygon command hides occluded (rear) points of the same object.