Snap to isoparm?

I tried searching, but the nomenclature in Rhino seems different from the software I’m used to, so I’ll try an illustration instead:

How do I snap to an isoparm?


This is an imported .step file, and red markings are isoparm end points, while blue are mid points (and the free floating is the center of a span).

You need to use OnSurface (OnSrf) one-shot object snap. One-shot object snaps are transparent (work while a command is running). Before picking a point you can either type OnSrf, or hold the Ctlr key down and select it from the osnap Toolbar.
You can also use Between one-shot object snap to snap on midway between two specified locations.

Thank you!

Wow, that was super unintuitive. I would never have found that out myself.

I’m still not 100% I’m doing it correctly, because when I hold down control on the snap option, and they switch to the “one shot” options, they’re all greyed out, and when I click OnSrf, the checkbox mark disappears when I let go of the mouse button.

One-shot object snaps only work when Rhino is requesting a point, are turned on for one pick only, and override all persistent object snaps for that pick.

Hello - The one-shots will be ‘live’ when Rhino is actually looking for the point - wait until you actually need it to ask for it. Note the ‘PersistentOnSrf’ as well, btw. Along surface edges the Knot osnap will find the ends of isocurves that are at knots.


There is a very nice option in Rhino called “export with origin” that seemingly lets you select a new origin for your exported selection.

However, I wasn’t able to get any of the one shot surface snapping to work with that feature. It just says “OnSrf” on the snap popup, but ignores all iso curves.

Hi - I’m not seeing that here - but you will, of course, have to enable the Int snap to be able to snap to intersecting isocurves. So, when you have gotten to the point where the cursor says “OnSrf”, type Int.

1 Like

Thank you!

Well - you’ll notice that this causes the export to fail - I’m writing up a bug report on that now.

Ah, yes. The resulting file is empty. That’s unfortunate.

That’s correct.
I see that it was like that in Rhino 5 as well, so this one will have to be fixed in Rhino 7.

Oh, aren’t point releases years between them in Rhino, with an associated upgrade cost as well? There’s no service pack releases each year for bug fixes?

Hi - yes, traditionally there have been a few years between each major Rhino version, and this is associated with an upgrade cost.

For Rhino 6 for Windows, we are now at Service Release 13, with SR 14 being around the corner. The last SR for Rhino 5 was SR 14.

At this point, we are focused to release Rhino 6 for Mac. Fixes to the Windows version are limited to crash fixes, regressions from Rhino 5, and critical SDK enhancements.

Note that fixes in Rhino 7 are available in the regular WIP versions, and as such, it is possible that your access to this particular fix is not years away.

Thank you for the information!

There’s at least two workarounds that I can think of so in this case it’s not a very big issue.

1 Like

Sorry for bringing this up again, but I’m still having trouble with this functionality:

I choose to relocate the Gumball. I enter the OnSurface command manually. I select the isoparm I want as origin. I right-click to accept the default orientation, and then the Gumball disappears.

Also, I wrote above that the “OnSurface” snap options were greyed out, but I must admit that I can’t even find them now. Where is the mouse input way of activating the on surface snapping?

When creating a start, end, direction arc, the onsurface command doesn’t seem to work.

I start the arc via the standard menus, and then when I want to select the end, I type onsurface in the command line, which then asks me to select the surface. What happens then is when I click, the arc command immediately jumps to the direction, and skips the end selection.

(Also, whenever I want to snap to a surface, I have to look up this thread. This command, and the way it is done, is really impossible for a new user. Why isn’t onsurface an option next to all the other snap options?)

The ‘one shot’; osnaps are fundamentally different than the standard ones that can be active all the time so these are separated out.

I see the problem you report about the OnSrf snap and Arcs though… I’ll see if that can be tuned up.


1 Like

Not to me as a user, though. I want to snap to a surface, I look near the snap options. They’re all down at the bottom of the app. There’s object snap, grid snap, gumball snap, but no surface snap, so the logical conclusion is that it doesn’t exist. The effect is that it might as well not exist.

But since it does, hiding it from the user makes no sense to me. It just reads as an UI flaw.

Hello - there are many too many snaps to put them all on screen - but I get that these are not immedately discoverable at the top level. However, they are in Tools> Object snaps, and of course on the Ctrl-hover and Shift-hover of the standard Onsap toolbar.

One shots, with Ctrl down:





@pascal, why this isn’t a standard behavior?