Snap function for curves and polycurve problems

Im having more and more difficulties with some kind of weird snap to seemingly random objects.
When i use the line or polyline tools it keeps want to force snapping to various objects. It will also be stuck on certain points and not beeing logic even to a ‘normal’ snap function.
For now it wont even let me set out the first point for a curve, no matter the view.

I can not un-snap more than in perspective view.

Not even with all boxes unchecked for any snap setting.
Im on Rhino for Mac and have latest update installed (today).

I think it also happens only in Sub-D model files. But still wont work when i deactivate selection for SubD objects.

Does anyone know if there is a specific setting somewhere to solve this?

Dear user220 - welcome to the forum - maybe you want to be present at least with your first real name ?
can you post a screenshot from your interface ?
did you check both the persistent an the one-shot settings ?
do you have Grid snap turned on ?
did you already restart your computer ?

i am not sure where to reset Rhino for mac - tried a fast search but found not exactly what i was searching…
There is some info for the windows Version
https://wiki.mcneel.com/reset_to_defaults
@mary
is there a Mac Version for above steps ?

Edit

  • found something:

you can try to backup your preferences and then reset them
https://wiki.mcneel.com/rhino/mac/resetprefs

there are 3 commands available in rhino

_ExportPreferences
_ImportPreferences
_ResetPreferences

kind regards -tom

Hi!
Thanks for tips:

Blockquote

did you check both the persistent an the one-shot settings ? Yes
do you have Grid snap turned on ? No
did you already restart your computer? Yes

Now also tried to set to Default but still all is a ‘blank’

A picture is not of use since it wont screencap cursor icon (which is a ‘forbidden’-symbol now after update).
It got worse after Rhino softw update made today in fact.

Dear Daniel - maybe do a screenrecording (video) with stand quicktime player
Quicktime Player → File → new Screenrecording. there is the option to capture mouse-Clicks …
see here

and

kind regards -tom

Hi Daniel - can you check Preferences > Modeling aids > Snap radius - is that a reasonable number? (I think 15 is default)

-Pascal

Hi Pascal!
Thanks - Did check and it was 15 :slight_smile:

Hi Daniel - does the problem show with any file, even a brnad new one with say just a few boxes and curves added?
-Pascal

1 Like

Its a bit funny coz it wont allow snap in a file with SubD but in others it lets me draw crvs but no snap…


Hi Tom! Hope this works and shows the issues. Note it works in perspective but no other view.

dear daniel - maybe you somehow messed up the c-planes in the viewports ?
if you start a new file based on a template - maybe copy paste some geometry from this file - still the same ?

viewport - reset is in this toolbar - right mouse botton, sometimes you have to click twice - (a bug ?) → default 4 viewports
Screenshot 2021-10-25 at 21.10.44

1 Like

if you draw a _box - does it behave like expected this will show you in a simple way if cplane is correct

this is why i think your cplane is wrong:

if you are in one of the orthogonal views (top, front, … ) cplane coordinates should vary in x,y but not in z
see y= 0.000 in the lower right

looks like the x-z direction is indicated in the lower left of the viewport.

not sure what your setting is for “project” you can t see it because of the scrolling in the osnap section below the left toolbar.

i recommend to work with end and mitpoint snap as persistent and use the snap function (osnap toolbar) for additional one-shot snaps.
(windows version has nicer shift click option)

does this help ? kind regards - tom

In settings do you have snap to occluded objects on?
If so try turning that off it really misbehaves in a shaded view.
RM

Hey, thanks! Where in settings can i find this?

Thanks again! I think the Z is correct in all views? Not sure what you’re refering to since construction planes and how they work is not to my full knowledge, i believe.
I never use gridsnap if you’re refering to that?

Ive copied sole surfs and curves in a file (but excluded SubD’s) and then it works mainly fine, except that it wont snap on anything in that case.

Tried this now and it seemed to solve the problem! Many thanks @Tom_P :+1::pray::raised_hands:

Hi Tom,

You actually do not need to back up your preferences if you do not want them back.
You can reset your PLIST on the Mac and it will reset your Preference to the default, the way Rhino was when it was when it was first installed.

Just follow the instructions under the title: Reset Rhino Preferences.
You can skip the “Save copy…” and “Restore copy…” part is you just want a clean reset.

This will not reset any Document settings. For this, you can import your 3DM into a new 3DM. Many times the issue with the document is left behind.

Happy to see this issue appears to have been solved with all your helpful suggestions.
Sincerely,
Mary Ann Fugier