Small buttons display in high resolution 15" monitor - Solved

unhandled

#1

Hi everyone,

I’ve installed Rhino5 on my Dell Precision m4800 with 15.7" monitor.
My resolution is 3200x1800.

I’m using windows’ DPI 150% and it seems it’s not affecting Rhino.
Also, i’ve enlarge the button size in Rhino’s Options -> Toolbars -> Sizes and Styles -> Button Size to Large which is the maximum size allowed and still it’s not big enough.

It’s almost impossible to work like this and i dont want to downsize my screen resolution. Is there any other way to custom-size the buttons?


(Pascal Golay) #2

Currently, no, there is no way to make Rhino buttons larger than the built-in large size (48 pixels).

-Pascal


#3

Could you please supply a screen shot of the work space showing how small the buttons are.
I have been avoiding upgrading my laptop for this very reason and would like to see exactly how small they are.
Vern,


#4

Hi,

I’ve attached a screen shot, my resolution is 3200x1800 and as I mentioned in the previous message I’ve raised the buttons size from ‘small’ to ‘large’ in the Rhino Options.

My complaint about the button sizes was more than two months ago and i must admit - I got used to it, so I think you can too. :smile:
Even tho the buttons might look small, they’re not really that small and you can see your Rhino Model much more clearly than in smaller resolutions.


#5

Hi,

That is excellent, thank you.

I actually avoid 3D work on my laptop (1366x768) while on the move as it feels a little claustrophobic after working on a high res 27" workstation, this will change that.

one more question, Have you and how was your experience with using the adobe collection on the 3200x1800?
I’ll be using Photoshop, illustrator, in-design, premier Pro and after aftereffects.


#6

I’m bringing this topic back up since it’s still an issue… I have a 3200x1600 display as well. The icons are, as you say, really tiny.

The WIP of Rhino 6 has fixed this - larger icons are evidently available so it looks great in v6.

Any hope of seeing this in a service pack for v5?

Grasshopper has the same issue. Realllly teeeny icons there. Completely unusable except by memorizing placement or using tooltips.

Thanks,
Mark


(John Brock) #7

Hi
The changes we are making for V6 can not be implemented in a V5 service release, so no, sorry.
V6 it is.


(John Brock) #8

With a System Registry key addition and copying a manifest file to the folder where 64-bit Rhino V5 lives, you can fix the small icon problem on high resolution monitors.

The details are in this new FAQ support document:
http://wiki.mcneel.com/rhino/5/video/highres/toolbars_and_text_too_small_in_64-bit_rhino_5_on_high_resolution_screen

This also fixes the same issue for Grasshopper in 64-bit V5


#9

Have a new 4K laptop screen and a standard resolution 2nd screen. When I import a pdf file into a new rhino file, the previously full screen rhino display (on either monitor) reduces itself to a small size, with minuscule tabs and text. The tab and text size does not readjust when I optimize window again. The only way to get a usable interface is to save & close the file and reopen. Is this a high res screen issue or a common rhino problem? This is the first time I’ve used rhino on a PC and I am still on trial version. Does the full install correct this issue? The rest of the time the display is fine- didn’t need the registry key change discussed above for optimized display.


#10

I’m having this issue on my Microsoft Surface Book at full resolution. I’ve tried the above regedit solution and the problem persists.


#11

CORRECTION: I was still running in “compatibility mode for Windows 7” and with “display scaling on high DPI setting” disabled, both from previous attempts at fixing the issue. After turning both off again the above regedit link took effect. Problem solved. Thanks!


#12

I had the small icon problem too with my 15" monitor with high resolution. I downloaded support document, my icons are bigger, but now rhino got pixelated, low resolution view, worst than ever. I followed the instructions in the link, what did I do wrong?


(John Brock) #13

What display adapter is Rhino using?
Options > View > OpenGL and take a screenshot of the settings on that page


#14


(John Brock) #15

That looks OK. It’s the current driver too.

Any chance you have a Windows Compatibility mode set on the Shortcut Properties?
If there is, you don’t want one.


#16

I think it looks ok too.


#17

Hi, first of all thank you John for this patch, it solved a big problem for me. I also suffered from huge crashes of Rhino because of full memory on a 5K Dell display.

I applied the patch and had the same problem with an pixelated viewport like Ece_Ema.
Solved it by disabling “custom scale” in the Win10 display settings and setting the Zoom-Factor to “200% (recommended)” in WIN 10

Now everything works perfect!


(Ufuk Bircan Özkan) #18

OpenGL page screenshot reports that the GPU has 64MB of VRAM. Same here on Surface Book with 1GB NVIDIA GPU, it doesn’t show 1024MB RAM. Is it only a display bug on the options page or does Rhino really can see 64MB of it?


(John Brock) #19

@ufubo
Please repost this in a new message with an accurate subject. You message will not be seen here and is unrelated to the topic.