Slow viewport

Sometimes when i do a extrude planar curve to make a solid my viewport, or rhino, responds extremely slow and allmost freezes. If there is a panel in the screen it starts to glitch in white. I have the same behaviour with pushing the alt-button and then using the gumball to make and move a copy.
I hav a holomarkscore of 63225 and an nvidia quadro k2200 on win 10 64 bits. Rhino is up to date and the fiel is not extremely big.
What could be causing this?

Kind regards, rené

Not sure if this will help, but… have you tried the tips at ?

Thanks. I tried and used the recommandated settings but to no avail.

Can you get us a screenshot of what you have in Tools, Options, View, Open GL?

Is that happening also on the WIP?

I guess you mean this part?