Slow/Unresponsive Printing to PDF

layout
printing
rhinoformac
bug

#1

After the 10.13.3 update to High Sierra I’m having some issues printing layouts to pdfs. I’ve restarted Rhino, RhinoWIP, the computer, did a PRAM reset and am unable to print what I need.

Along with that issue when selecting vector instead of raster it still prints out as a raster in PDF format.

Software information

Software versions
Rhinoceros version: 5.4 WIP (5E374w)
Rhinoceros path: /Applications/RhinoWIP.app
IronPython version: not installed
WIP expiration: February 23, 2018
Evaluation expiration: April 18, 2018
Language: en-US (MacOS default)
macOS version: Version 10.13.3 (Build 17D47)

Plug-ins
/usr/lib/closure/libclosured.dylib
/Library/Printers/hp/PDEs/hpPostScriptPDE.plugin/Contents/MacOS/hpPostScriptPDE
/Library/Printers/hp/Frameworks/HPSmartPrint.framework/Versions/A/HPSmartPrint
/Library/Printers/hp/PDEs/hpPostScriptPDE.plugin/Contents/PlugIns/SmartPrintPostScript.plugin/Contents/MacOS/SmartPrintPostScript

Third party kernel extensions
com.logitech.manager.kernel.driver (6.72.1) A732FB9D-FD43-30B5-A891-1CE84334F39B
com.osxkernel.SolsticeAudioDevice (1) DCD1685B-6C34-351F-802D-4A291864AA9E
com.globaldelight.driver.Boom2Device (1.2) 5050B3EC-655D-3B74-BC81-81463887C253
com.paloaltonetworks.kext.pangpd (1.0.0) 2EB7232F-AC35-3CB5-81B3-D81783A18EEF
com.vmware.kext.vmci (90.8.1) F673BA9E-4370-3867-996E-CA6615DFDE0A
com.vmware.kext.vmnet (0752.01.54) 9EDDE1C1-80D8-3154-95A1-25F70585272E
com.vmware.kext.vmx86 (0752.01.54) F20CC4A3-BFB5-365B-AEB8-84796FAA26F4
com.vmware.kext.vmioplug.17.1.3 (17.1.3) 4E465B8F-BBF2-3877-BB4B-17398E62310C

Hardware information

Computer hardware
Hardware model: MacBookPro11,4
Processor: Intel Core i7-4770HQ CPU @ 2.20GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel Iris Pro 1536 MB
Memory: 1536 MB
Screen size: 1920 x 1200
Displays: Color LCD (295dpi 2x)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Broadcom Corp.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-10.30.14
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#2

Uninstalling and reinstalling both Rhino for Mac and RhinoWIP for Mac did nothing, along with another PRAM reset and SMC reset (because why not). Uninstalled a bunch of programs that had nothing to do with rhino to make sure there wasn’t a conflict but still not fix.

Export to AI works fine but printing to PDF in vector output does not work, printing in general is either slow or causes a crash


(Dan Belcher) #3

Apologies for the slow reply.

Thanks for submitting your system info. Did you update your printer drivers? You also have a number of third-party kernel extension - some I recognize; some I don’t. You might try booting to safe mode (which disables those extensions temporarily until you reboot) and seeing if the issue persists.