Slow undo still here

i’m still seeing the slow down when undoing. i gave it a couple of days to make sure.

any ideas on what i can provide? thanks.

Rhino 7 SR3 2021-1-12 (Rhino 7, 7.3.21012.11001, Git hash:master @ 93cfba46488299a62365c4ea00af2e011f3d3950)
License type: Evaluation, build 2021-01-12
License details: Stand-Alone
Expires on: 2021-03-08

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP  - Plugged in [100% battery remaining]

Hybrid graphics configuration.
  Primary display: Intel(R) UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 12-11-2020 (M-D-Y).
    > Integrated graphics device with 3 adapter port(s)
        - Secondary monitor is laptop's integrated screen or built-in port
        - Windows Main Display attached to adapter port #1
  Primary OpenGL: NVIDIA Quadro P1000 (NVidia) Memory: 4GB, Driver date: 12-31-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.09
    > Integrated accelerated graphics device (shares primary device ports)
        - Video pass-through to primary display device

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  
  Anti-alias mode: 8x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 12-31-2020
  Driver Version: 27.21.14.6109
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 7\Plug-ins\Commands.rhp	"Commands"	7.3.21012.11001
  C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp	"WebBrowser"	
  C:\Program Files\Rhino 7\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp	"RhinoScript"	
  C:\Program Files\Rhino 7\Plug-ins\RPC.rhp	"RPC"	
  C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp	"IdleProcessor"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	7.3.21012.11001
  C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp	"Legacy Rhino Render"	
  C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	7.3.21012.11001
  C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp	"Alerter"	
  C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp	"IronPython"	7.3.21012.11001
  C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	7.3.21012.11001
  C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	7.3.21012.11001
  C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp	"Displacement"

I was going to mention this too. There is a delay when using Undo that wasn’t there in previous versions.

I noticed this too. For me it seems like the very first undo is ok, but any more than a single undo takes several seconds per undo. This behavior was much faster not that long ago. Any word on this issue?

Rhino 7 SR4 2021-3-8 (Rhino 7, 7.4.21067.13001, Git hash:master @ ed629035202f07e8b84a3ee211479ca20bb81b73)
License type: Educational, build 2021-03-08
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP 

Standard graphics configuration.
  Primary display and OpenGL: NVIDIA Quadro M5000 (NVidia) Memory: 8GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
    > Accelerated graphics device with 4 adapter port(s)
        - Windows Main Display attached to adapter port #0

Secondary graphics devices.
  NVIDIA Quadro K2200 (NVidia) Memory: 4GB, Driver date: 1-22-2021 (M-D-Y).
    > Accelerated graphics device with 4 adapter port(s)
        - There are no monitors attached to this device!

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  
  Anti-alias mode: 8x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 1-22-2021
  Driver Version: 27.21.14.6140
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 7680 MB

Rhino plugins that do not ship with Rhino
  C:\Users\modulok\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.0\IntelDenoiser.Windows.rhp	"IntelDenoiser.Windows"	0.1.0.0
  C:\Users\modulok\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp	"NVIDIADenoiser.Windows"	0.4.0.0

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 7\Plug-ins\Commands.rhp	"Commands"	7.4.21067.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 7\Plug-ins\RPC.rhp	"RPC"	
  C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp	"AnimationTools"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	7.4.21067.13001
  C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp	"Legacy Rhino Render"	
  C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	7.4.21067.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	7.4.21067.13001
  C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	7.4.21067.13001
  C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Program Files\Rhino 7\Plug-ins\Calc.rhp	"Calc"

Agreed… I’ve been using 7 for 20 days and there is definite latency with undo. Though, if I use ‘redo’ and then ‘undo’ again, the second undo is normal speed