Slow start of Rhino: McNeelUpdateClient


(Menno Deij - van Rijswijk) #1

When debugging, I frequently need to restart Rhino. I noticed that after this line appears in the debug output, that loading stalls for up to 20 seconds.

'Rhino.exe' (Managed (v4.0.30319)): Loaded 'C:\Program Files\Rhinoceros 5.0\System\McNeelUpdateClient.dll'

Is there any way to skip this, or speed this up? What is happening when this is loaded? If an update check is being made, can that be (temporarily) disabled? I have switched off "Enable updates and usage statistics but that makes no difference.


(Dale Fugier) #2

I debug all day and I don’t have the delay you describe.

Are you automatically loading symbols? (Visual Studio: Tools -> Options -> Debugging -> Symbols) This will definitely slow down Rhino’s load time.

– Dale


Disable Automatic Update Check for Rhino 5