Slow rotation and zooming 2014-11-10 (5A580)

Yeah I’ve been having the same problem. I’m not sure if it was to do with updating rhino or not as it happened at the same time as updating to OS X Yosemite/ 10.10. Also Yosemite broke Toucan Renderer. Hopefully these get fixed

This issue is driving me crazy. I think zooms should stop moving when you stop moving mouse or track pad. This totally breaks Rhino OS X for me.
Started when I upgraded to Yosemite. But I am worried it is a case of clever UI. Please don’t be clever we are trying to get things done. I was able to repeat this with just two curves in a new document. It resolves quickly but the zoom continues to move when I let go of the trackpad.

Problem is with trackpad on Macbook pro late 2013.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-10-15 (5A554)
IronPython version: 5.1.2014.1006
Language: en (MacOS default)
OS X version: Version 10.10 (Build 14A389)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: MacBookPro11,1
Processor: Intel Core i7-4558U CPU @ 2.80GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel Iris (null)
Memory: 1024 MB
Screen size: 1280 x 800
Displays: Color LCD

USB devices
Apple: Internal Memory Card Reader
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-10.0.86
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

[quote=“Carbett, post:3, topic:12741, full:true”] But I am worried it is a case of clever UI. Please don’t be clever we are trying to get things done.
[/quote]

not clever UI… it’s a known issue and appears to be yosemite related.

Just for a note I was unable to repeat this problem on another computer with a Magic mouse.
Mac Mini Late 2012. Yosemite. Same files with this version of Rhino. All files are zooming normally.
Sorry for previous tone but I had work due tonight. Good thing on this other computer zoom works perfectly.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-08-27 (523)
OS X version: Version 10.10 (Build 14A389)

Plug-ins
/Library/Printers/hp/PDEs/hpPostScriptPDE.plugin/Contents/MacOS/hpPostScriptPDE
/Library/Printers/hp/Frameworks/HPSmartPrint.framework/Versions/A/HPSmartPrint
/Library/Printers/hp/PDEs/hpPostScriptPDE.plugin/Contents/PlugIns/SmartPrintPostScript.plugin/Contents/MacOS/SmartPrintPostScript

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: Macmini6,2
Processor: Intel Core i7-3615QM CPU @ 2.30GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel HD Graphics 4000 (null)
Memory: 1024 MB
Screen size: 2560 x 1440
Displays: LED Cinema Display

USB devices
Fujitsu: ScanSnap S500M
Griffin Technology, Inc: iMic USB audio system
Canon: CanoScan
Apple Inc.: Display iSight
Apple Inc.: Apple LED Cinema Display
Apple Inc.: Display Audio
Apple, Inc: Apple Keyboard
Apple Inc.: Bluetooth USB Host Controller
Apple, Inc.: IR Receiver

Bluetooth devices
Apple: Apple Wireless Mouse

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-10.0.86
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

This bug (?) occurs for me as well and I’m using 10.8.5 (not Yosemite) on a late 2008 Macbook Pro…
As others have mentioned, this seems to be a new problem since previous Rhino builds where very responsive to trackpad gestures for zooming, translating and rotating (despite my somewhat ancient laptop). But now all these are now very very slow with a delayed response (ie the model keeps moving long after trackpad gestures are finished).

thanks,

  • Claude

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-10-14 (5A552)
IronPython version: 5.1.2014.1006
Language: en (MacOS default)
OS X version: Version 10.8.5 (Build 12F45)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: MacBookPro5,1
Processor: Intel Core2 Duo CPU T9550 @ 2.66GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce 9400M 256 MB
Memory: 256 MB
Screen size: 1440 x 900
Displays: Color LCD

USB devices
Apple Inc.: Built-in iSight
Apple Inc.: Bluetooth USB Host Controller
Apple, Inc.: Apple Internal Keyboard / Trackpad
Apple Computer, Inc.: IR Receiver

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.16.80 310.40.00.20f04
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: Medium

Hello again,

the problem is only with the trackpad. When I use a mouse, Rhino is responsive. I am using mac os X 10.8.5

I am looking forward to the new release of the wenatchee…

Hello Everybody,

I installed today the new release of the Wenatchee 2014-11-05 (5A574). Unfortunately, it is still unresponsive to the trackpad :frowning:

Hector

@Hector

i think marlin can duplicate the problem now and will be able to fix it… so, hopefully by the next release it will be squashed

Thanks! :smiley:

Today I downloaded the update which should end the problems with the trackpad but the problems still exist. Not all the time but, as far as I can see now, after turning on another layer. Suddenly it isn’t possible to pan, instead the program zooms in or out and sometimes continue doing this after I take my fingers from the trackpad.

Same Here I have the newest Build on November 11 2014. Notes for release mention improved track pad pan and zoom. Well if it is a little bit better it is not good enough. Two problems. 1 slow zoom that continues after you take your fingers off the track pad. More pronounced depending on how large the file is. 2 there is a problem where the pan stops working when using track pad for brief periods of time. However while pan is failing suddenly the zoom feature appears and works perfectly when a pan should be occurring.

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-11-05 (5A574)
IronPython version: 5.1.2014.1006
Language: en (MacOS default)
OS X version: Version 10.10 (Build 14A389)

it says panning and rotating …not zooming… that’s the same change log as last time around.

but this release (nov11) is a rushed one in order to figure out a problem with the licensing system.

Problem is solved. My update did not show up until tonight, My Bad. Pan works well and zoom no longer goes on without me. Back to work on Rhino on Macbook Pro. Thanks to all that got this working again.
Software versions
Rhinoceros version: 5.0 Wenatchee 2014-11-10 (5A580)
IronPython version: 5.1.2014.1006
Language: en (MacOS default)
OS X version: Version 10.10 (Build 14A389)

On my Mac panning/rotating using the trackpad is still a problem in Perspective view - huge lag and very jumpy, zooming works fine though oddly enough. The other default views work fine now with panning and zooming (thanks!).

My model isn’t very big and panning used to work well several builds ago so I don’t think it’s my Mac.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-11-10 (5A580)
IronPython version: 5.1.2014.1006
Language: en (MacOS default)
OS X version: Version 10.8.5 (Build 12F45)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: MacBookPro5,1
Processor: Intel Core2 Duo CPU T9550 @ 2.66GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce 9400M 256 MB
Memory: 256 MB
Screen size: 1440 x 900
Displays: Color LCD

USB devices
Apple Inc.: Built-in iSight
Apple, Inc.: Apple Internal Keyboard / Trackpad
Apple Computer, Inc.: IR Receiver
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.16.80 310.40.00.20f04
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: Medium

Aha! I just fixed the problem by hiding that floating tool palette (which was kind of annoying to begin with). Once the tool palette was gone the Perspective View panning suddenly worked great! The palette window seems to mess with trackpad events.

Anyways, hopefully this might provide a hint as to where the bug is.

For those, like me, that had trouble figuring out how to hide the default floating tool palette: Windows->Active Tool Palettes->Main
It would be great if the ‘close window’ button on that particular palette worked. I just figured it was impossible to hide it until I stumbled upon the menu option.

that may be a clue about the bug but at the same time, i did something equally mundane as closing a toolbar which also ‘fixed’ the problem… that being Rhinoceros-> About Rhinoceros-> click on the splash screen to close it… viola, the panning/rotating was ‘fixed’…

however, it’s since come back and i would do that ^ again and it would go away again :confused:

also, there are two separate issues with the trackpad and i’ve experienced (am experiencing) both of them…

• 1- trackpad completely unresponsive to 2finger swiping be it rotation or with the shift key, panning… the model/camera doesn’t move regardless of the actions on the trackpad.

• 2- ‘sluggish’ zoom with 2finger pinch gesture… a pinch causes the zoom to happen in what seems like slow motion… nothing else can happen until the zoom process is complete.

with the second one, i’ve been able to unhide everything then copy/paste a model into a new file and the problem went away… zooming was completely responsive… however, i can’t do that on all files… sometimes, i’ll copy/paste a ‘problem’ model into a new file and the zooming problem persists…

anyway… it seems like a complicated problem with a few temporary ‘fixes’ which users have stumbled across… i’m not really sure how exactly to communicate these issues with marlin when i’m experiencing them.

In my case turning on a layer makes panning impossible. I use a trick, miniaturise the window by clicking the yellow button top left and back again. That is makes panning possible again at least in my case. I use Yosemite 10.10 and a MacBook pro 2.3 GHz, Intel Core i7. Its is a provisional trick but maybe it works with others.

I appreciate this tip. Panning now working better for me. Yes the problem starts for me now when I select a layer. Clicking the miniaturize button works well right now. Seems to me that there are weird issues with the macbook track pads.

It happens with the magic mouse as well, Almost like rubber band scrolling in iOS