Slow rendering on V6

I have a pretty simple model that when I select Render as a view and rotate the image the performance is slow. When I export the file and open it up on V5, the render is smooth as expected. What is required to get the render view to work as it did in V5 where you can rotate freely without the model freezing as it’s trying to redraw the model?

I have the latest Macbook Pro so I’m surprised that rendering is slow.


I’ve attached the model in question

PIQO.3dm (4.7 MB)

Sorry to say it, but this and similar issues were raised during the beta. Some improvements were made but yes, it is slower

I can understand the perhaps Raytracing would be more taxing on performance but Render View should be at least the same as V5, currently it’s unusable and I’m surprised Rhino would believe that it’s ready for production with the lag in viewing models.

I’ve tested your file on my 2016 MacBook Pro (2.9 GHz i7, Radeon Pro 460 4 GB) and the Render view is pretty fast. There’s no lag when moving the object or paning/rotating the view. I’m using the latest Rhino service release candidate (6.17.19218.01052, 2019-08-06).


Arctic view is fine too, sure it’s a little slower, but it can be worked with live.


Raytraced is still pretty buggy on macOS and prone to crashing Rhino, but for your model it works fine. Here’s the result after rendering for about 15 seconds at 1000 samples.


What are your specs?

I’m on a MacBook Pro (15-inch, 2018) with the following 45%20AM. It’s really the rotating of the object which lags, it’s just not as responsive as it was in V5. If I spin the object quickly it just drops frames.

I’m on version Version 6 WIP (6.16.19197.13284, 2019-07-16), I can’t seem to find where you got your version from?


Yeah, I’ve just gone back into V5 for the first time in a while and it feels amazing in comparison. So smooth! Maybe I’ll enjoy modelling again now I’m going to have to revert to it


I tested your file here on a 2013 MBP and Rendered mode doesn’t have a lag. I think that maybe your better GPU isn’t being used by Rhino 6. Can you run the command “SystemInfo” in Rhino 6 and copy and paste the text back in reply here please? Rhino 6 has skylight shadows in the Rendered display mode and this requires better graphics. Rhino 6 also has a ground plane object that is on by default. Show your Rendering panel by clicking the gear icon in the panels on the right. In the lighting section you can disable the skylight as a test as well. I think that your performance will then be similar to v5 using the Intel 630 GPU which I bet is the one that’s active.

Let me know what you find please. I can help you make the better GPU the one that Rhino 6 uses if that is the issue.

I wonder if you may also have the lesser GPU running in Rhino 6. Let me know your SystemInfo from running that command in Rhino 6 if I can help. The Rhino 5 Rendered display mode is not doing the same things as the Rhino 6 Rendered display mode as I mentioned above so it requires better graphics. You can always disable the skylight too to get a more v5 style Rendered mode. Let me know if I can help.

Under General in the preferences pane, switch the Update Frequency to Service Release Candidate. This will allow you to install test versions of the newest Rhino 6 so to speak.

This probably has nothing to do with your problem though.

Thanks, I’ll try turning off the skylight. The integrated GPU is definitely not that great on the MacBook, but the difference in performance between V5 and V6 bets are so huge.

To be honest, it is the whole app. The viewport is obviously the thing that you use the most but every tool, every window and panel is just so sluggish. Not to the point of being unusable, but definitely impacting the experience. The ones that I listed are absolutely dreadful (materials, named views). So much beach balling which really games productivity because it takes so long you start doing something else while waiting.

Edit: sorry, I thought this was on this thread: Major performance issues in V6

Sorry for the confusion

I replied in that other thread, this one may be related as well. Thanks.

Thanks Brian for the information, here is the output of systeminfo

Rhino 6 SR16 2019-7-16 (Public Build, 6.16.19197.13284, Git hash:master @ 007ddfea645de8e7b1a90e433246ed90f938d0b7)
License type: Beta, build 2019-07-16
License details: Stand-Alone
Expires on: 2019-08-30

Apple Intel 64-bit macOS Version 10.14.5 (Build 18F203) (Physical RAM: 32Gb)
Mac Model Identifier: MacBookPro15,1
Machine name: Michael’s MacBook Pro
Language: en-US (MacOS default)

AMD Radeon Pro 560X OpenGL Engine (OpenGL ver:4.1 ATI-2.9.26)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: Radeon Pro 560X
Displays: Color LCD (258dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
Radeon Pro 560X (4 GB)
Color LCD (1680 x 1050)

USB devices
3Dconnexion: SpaceNavigator
Apple Inc.: iPad
VIA Technologies Inc. : USB 2.0 BILLBOARD
Generic: USB3.0 Card Reader
Realtek: USB 10/100/1000 LAN
Apple Inc.: iBridge DFR brightness
Apple Inc.: iBridge Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: iBridge ALS
Apple Inc.: iBridge FaceTime HD Camera (Built-in)
Apple Inc.: iBridge

Bluetooth devices
Broadcom: Wireless iAP, SPP Dev, Wireless iAP, SPP Dev, Hands-Free unit, Headset
Broadcom: Magic Keyboard
Broadcom: Magic Trackpad 2

Third party kernel extensions
org.virtualbox.kext.VBoxDrv (5.2.30) 00DDD798-DE99-34BF-91DB-96C73BFD3993
com.3dconnexion.driver (1.1.0) 94E8C49C-EDED-3526-88BE-E7207560C0D2
org.virtualbox.kext.VBoxUSB (5.2.30) E3DCC109-D122-3907-A593-E0326AEB894E
org.virtualbox.kext.VBoxNetFlt (5.2.30) 43EBFA5E-CD8A-34BF-B370-BDBFB752E462
com.kairos.driver.DuetDisplay (1) 7620686C-E9CE-3C70-AA12-DC77DABA52DD
org.virtualbox.kext.VBoxNetAdp (5.2.30) 4D38C28B-F9EA-3661-82D8-7B679DA8DB46
com.paloaltonetworks.kext.pangpd (1.0.0) 2EB7232F-AC35-3CB5-81B3-D81783A18EEF

Third party plugins

Rhino plugins
/Applications/ “RhinoCycles” 6.16.19197.13284
/Applications/ “STL Export” 6.16.19197.1002
/Applications/ “Snapshots” 6.16.19197.1002
/Applications/ “Grasshopper” 6.16.19197.13284
/Applications/ “PanelingTools” 6.16.19197.1002
/Applications/ “Commands” 6.16.19197.13284
/Applications/ “SolidTools” 6.16.19197.1002
/Applications/ “Renderer Development Kit” 6.16.19197.1002
/Applications/ “RDK_EtoUI” 6.16.19197.13284
/Applications/ “Displacement” 6.16.19197.1002
/Applications/ “IronPython” 6.16.19197.13284
/Applications/ “Rhino Render” 6.16.19197.1002

I tried changing the rendering settings and the one that seemed to work best is by turning off the Skylight setting for the lighting. Performance is now similar to V5.

I downloaded a trial version of 6.17 to see if there were some performance improvements, and it seems that the Skylight setting impacts performance. Any insight to get acceptable performance would be appreciated.


Hi Michael,

Thanks for the system info. It looks like my initial thought that your Rhino wasn’t using the better GPU was wrong. There is something else that may be involved here which was recently fixed where skylight shadows were not downgraded while rotating the viewport with a 3D connexion device. This fix is not currently in the 6.17 build for you to test but can you tell me if you are using a 3D connexion device? If so, is there a difference using a regular mouse?

Hi Brian,

I disconnected the 3d connexion and used the mouse and the performance doesn’t improve, it’s the same with the trackpad or the 3d connexion.


Thanks for testing that Michael. The only other suggestion I can think of for faster performance while using the Skylight in Rendered mode would be to tweak the resolution settings for it’s shadows in Preferences (cmd+,) > Advanced. Try making the dynamic setting 3 so that the shadows are grainier only on rotate.

A post was split to a new topic: Skylight shadow resolution