Sketching is impossible to use in V6 WIP at the moment


#1

… as it seems to have “ortho” enabled during sketching (making ugly polylines). The curve rebuilds when releasing the LMB, but that’s too late - you don’t get realistic feedback during sketching.

Philip


#2

I realize not many are necessarily using ‘sketch’, but I still would like to have this fixed. I have a couple of macros that make nice bezier curves on the fly sketching on my iPad with the pencil using ‘Astro pad’ for the connection to my Mac(s)…
@dan

Philip


(John Brock) #3

If I have Grid snap and/or Ortho on when I run Sketch, it acts as you described.
When they are off so I have full, free cursor movement, Sketch works as expected.


#4

Yes, I know. My point is that it should work as expected (with free cursor movement) even if ortho (and/or grid snap - which I never use) is on. That’s how sketch always has worked - and works in V5. That’s why I think it’s a bug.

Philip


(John Brock) #5

As far as I can tell, this was an intentional change for V6.
This is how Windows V6 works now.
I’ll check back with the developer and see if they remember.

Over the years, I recall there were a few complaints that Sketch ignored those controls so it’s quite possible the change was made intentionally.


#6

I’m sorry, but I really don’t understand the reason for making such a change. As I tried to explain in my first post it makes the command… well, impossible to use. It’s very easy to understand If you first try to sketch in V5 and then in V6. The new behavior in V6 doesn’t make any sense at all.
If it was an intentional change - please reconsider.

Philip


#7

Hello…? @dan, @marlin

Philip


#9

Hi Philip, I could only find one related item in the bug tracker system, but that was marked obsolete - perhaps @mikko remembers more?


(Mikko Oksanen) #10

@wim, both Sketch paying attention to grid snap and ortho were unintentional changes. Ortho was side effect of this: https://mcneel.myjetbrains.com/youtrack/issue/RH-31239
Grid snap was a side effect of a big change to how Rhino settings in general work. Grid snap used to be paid attention to before too, but only if you turned on gridsnap while in Sketch.
I’ll add a youtrack item for making these work like they used to.


#11

Good! :+1: Kiitos Mikko!

Philip


(Dan Belcher) #12

This was logged in RH-48709.