Simple trim refuses to happen

Hi V5.
I need to trim off the bit of green surface appearing within my trim cylinder.
I have exploded the green incase that helped though there was nothing to explode,
I have tried selecting the green long portion to see if cylinder needed flipping, it didnt trim so cant be that.
Why is such a simple task failing ?
cylinder was a circle extrude curve make surface.
green started life as a pipe.

simple trim fail.3dm (105.5 KB)



Run SrfSeam and rotate the cylinder seam out of the way.
It’s interfering with finding the intersection of the surfaces.
Then it will Trim just fine.

Or Intersect the two surfaces, and use the resulting curve as the trimming object.

Using that working display mode that hides seams, edges, and isocurves can bite you.
They aren’t there just to clutter the display.

1 Like

The seam thing, blimey not had that for years.

trouble is the extra lines add to the clutter and confusion, bad enough as it is on what I am doing.
I would be trying to hide things when they belong to what I am working on.

This could explain a few other trim fails, where intersect solved it . Using tube and pipe and sometimes trim failed.


As soon as I opened your file and saw where the seam was I knew what the easy work-around was.

1 Like

Shouldn’t Rhino spit out a error message explaining why it failed? (at least in cases where Rhino can know the cause of failure)

// Rolf

This will also work if you shrink the green surface before trimming it or Intersect first and trim with the curve. This seems slightly buggy to me.
Fixed in V7/WIP.