Significant drop in performance while in "Shaded" view

While working on a more complex project recently I noticed that the “Shaded” view burdens the video card with a significant drop of performance compared to my custom view modes. Even working with simple models such like the one from the video below makes the things too heavy on the video cars side and framerate drops to single digits. Interestingly, my custom view modes are all derivatives of the “Shaded” view, which is interesting, because they don’t suffer from the same drop of framerate and perform in a very fluid way. I’m using NVIDIA GeForce GTX 1660 Ti with the latest “Nvidia” graphics driver (In recent days I tried several studio drivers and game drivers), but I don’t think that this is the problem, because only the “Shaded” view causes issues with performance.

Take a look after the 4:50 minute of this video and you can clearly see that the “Shaded” view immediately tanks the performance compared to one of my custom viewport modes when the preview wireframe is shown upon creating edge fillets:

Also, when I work on some of my custom viewport modes and switch to “Shaded” view, Rhino 7 often takes some time to recalculate the mesh and sometimes freezes while doing so for several seconds if the scene consists too many objects. Not sure why this happens since the meshing settings from the Rhino options should be the same across all viewport modes.

That issue was present since the release of Rhino 7 at the end of last year even with the default non-modified “Shaded” view, but the latest few releases perform even worse. Any idea why Rhino 7 behaves in this way? :slight_smile:

Thanks,

Bobi

P.S.: Here is the Rhino 7 system information:

Rhino 7 SR9 2021-7-15 (Rhino 7, 7.9.21196.07001, Git hash:master @ a1dd75a58c25c687e78697cfd8dd921026123719)
License type: Commercial, build 2021-07-15
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP 

Standard graphics configuration.
  Primary display and OpenGL: NVIDIA GeForce GTX 1660 Ti (NVidia) Memory: 6GB, Driver date: 7-12-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 471.41
    > Accelerated graphics device with 4 adapter port(s)
        - Windows Main Display attached to adapter port #0

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 7-12-2021
  Driver Version: 30.0.14.7141
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
  D:\PROGRAMI\Rhinoceros 6\Plug-ins\Stereoscopic 3d viewport\StereoView.rhp	"StereoView"	
  C:\Program Files\ADA 3D\Mesh2Surface for Rhino 6\m2s_for_Rhino.rhp	"MESH2SURFACE"	

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 7\Plug-ins\Commands.rhp	"Commands"	7.9.21196.7001
  C:\Program Files\Rhino 7\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp	"RhinoScript"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	7.9.21196.7001
  C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	7.9.21196.7001
  C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	7.9.21196.7001
  C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	7.9.21196.7001
  C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp	"Displacement"

My current settings for “Shaded” view:

If you send the display.ini file then we can see if it specific to your config or not.

I have no idea how to export Display.ini , but I was able to export individual viewport modes. The funny thing is that my custom display mode called “Bobi 1” is a derivative of the default “Shaded” mode, but I changed it to show rendering material in the viewport.

Shaded.ini (13.8 KB)

Bobi 1.ini (13.8 KB)

I also should mention that the backface material while in “Shaded” mode appears in a slightly different colour than the front face material, despite the fact that in my setting both sides share the same material (Backface settings > Use front face settings).

what you did was what I meant :slight_smile:

fwiw, I see no big differences, but your Bobi_1 mode is slightly faster on my system than the Shaded view. I ran TestmaxSpeed to test this, but also just zooming in and out manually feels equally smooth on fairly dense models. I am certainly not seeing the delays you experience in the video.

Those delays and the recalculation of the rendering meshes sometimes cause crashes while working on Rhino scenes whose file size is above 1,5-2 GB.
For example, when I design something in my custom viewport mode and then switch to “Shaded”, there is a temporary freezing of Rhino 7 and it seems like the rendering mesh that was used thus far was completely deleted and then calculated again specifically for the “Shaded” view. And the latter it’s always much, much heavier on the video card than my custom viewport mode, especially during the preview of fillet edges.

In last days I got a couple more crashes with Rhino 7 upon switching to “Shaded” mode on a file which is 2,3 GB in size. The viewport is very responsive with my custom viewport mode that I uploaded above 10 days ago (it renders the objects with their own rendering material), but something in the “Shaded” mode seems quite heavy and that impacts the video card way too much. I believe that it may be related either to the environment map it uses to shade all objects with the same material, or a mess with the draw calls while rendering the polygonal geometry (the mesh is being recalculated upon switshing to “Shaded”). I have a dozen custom viewpoert modes that are derivatives of the “Rendering” or “Shaded” modes (with some changes to show their wireframe, etc) but for some reason they are multiple time faster than the default “Shaded” mode. I even have a custom mode that shows two different materials on each side of the surfaces (blue and yellow) and it’s still faster than “Shaded”.

There is very little in the Bobi_1.ini file that differs from both your Shaded.ini and the default Shaded.ini apart from the different use of materials and the use of scene lighting. The standout item is this:

Have you tried temporarily turning that off in Shaded as well to see if performance matches Bobi_1?

I turned that option off, but the worse performance of “Shaded” is still present.

By the way, I noticed that there is another topic on the first page with some people who also experience drop in performance in “Shaded” view.

I just uploaded a short video to show the issue. Upon switching to “Shaded” view Rhino 7 freezes for a while until it recalculates the mesh (not sure why it needs to do that) and this kind of annoying. This particular file was just 508 MB and Rhino froze for about 30 seconds. While manipulating the camera I easily felt the lesser framerate compared to my custom view modes. If a file is nearly 2 GB in size, Rhino sometimes crashes.

P.S.: Also, selecting mesh objects takes 7-8 seconds…

Have you tried disabling the third party plug-ins you have installed? It would be good to eliminate those as a possible cause.

I would also try pushing the “Restore Defaults” button for Shaded… or delete it altogether and let Rhino recreate it automatically… There are many settings that exist that some modes don’t use, but they’re still part of the mode descriptor…it’s possible that something has “snuck” into your Shaded mode somehow and it’s confusing Rhino some way somehow…

-Jeff

2 Likes

Hi Bobi

With an older GPU in Shaded view I’ve noticed a huge difference, especially with heavy meshes, enabling the last Option in the first page “Use advanced GPU lighting”.

-Michele

I tried that long time ago, but the performance seem to remain the same. The only difference is that the shading with the advanced GPU lighting is less contrasty, this is why I have it turned off.

I tried that, but no change in performance. :slight_smile:

Thanks, deleting the “Shaded” mode and auto-recovering it helped! There is still some small delay when I switch from my custom modes to “Shaded”, but it’s a lot shorter than before. For example, on the same file shown on my video where Rhino 7 froze for 30 seconds, this time around it froze for 6-7 seconds (shaving off 23-24 seconds is great). On some smaller files where the delay was 3-5 seconds before now it’s nearly instant. Another file of 2,3 GB that froze for more than 2 minutes before and crashed multiple times, now freezes only for 8-10 seconds (I opened it 3 times to make sure it’s not just a miracle that happens once in a live :sweat_smile:), which is where I see the biggest improvement. Up until now the framerate of this particular file was very slow in “Shaded” mode (basically a few frames per second), but now it runs almost as smooth as my custom modes and the framerate seems to be above 20-30 fps. :sunglasses:

As I mentioned in my original post, “Shaded” started to behave this way after one of the recent updates of Rhino 7 since end of last month. I also update my graphics drivers regularly, so I’m not sure what was the actual reason that caused that issue.