ShrinkWrap command line missing Hide input option and macro pain

The ShrinkWrap command line is missing Hide input option. Can this be added please?

The popup window to edit a button cannot be resized. I’m using 175 % scaling on my 4K displays.


I find editing a macro a bit of a pain compared to Rhino 7 since it requires opening two additional windows until anything can be edited. It was more straightforward in Rhino 7.

So far I was able to edit the macro and enter a Button / Menu / Help Text and Tooltip but my button does not update and when I close and open Rhino WIP my button is gone. My custom toolbar however is still there.

System info

Rhino 8 SR0 2022-12-20 (Rhino WIP, 8.0.22354.14305, Git hash:master @ f1d65b4b24f36d39a1fffe1cb9057a371ebed13d)
License type: Kommerziell, build 2022-12-20
License details: Cloud Zoo
Expires on: 2023-02-03

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 1.3e+02Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA RTX A5000 (NVidia) Memory: 22GB, Driver date: 11-23-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 527.27
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

Secondary graphics devices.
NVIDIA Quadro K2200 (NVidia) Memory: 4GB, Driver date: 11-23-2022 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-23-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 23028 MB

Rhino plugins that do not ship with Rhino
C:\Users\martinsiegrist\AppData\Roaming\McNeel\Rhinoceros\8.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\\KeyShot9RhinoPlugin\Rhino 7\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8 WIP\Plug-ins\Commands.rhp “Commands” 8.0.22354.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.22354.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.22354.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.22354.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoRoslyn.rhp “RhinoRoslyn” 8.0.22354.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.22354.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCPython.rhp “RhinoCPython” 8.0.22354.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.22354.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8 WIP\Plug-ins\ConstraintsUI.rhp “Constraints UI” 8.0.22354.14305
C:\Program Files\Rhino 8 WIP\Plug-ins\SectionTools.rhp “SectionTools”

RH-72160 ShrinkWrap: missing commandline line option hideinput

1 Like

I have a hard time seeing where you get this popup

regarding the macros editing, there are a few YT related to it.

RH-70165 Toolbar: Simplify the editing
RH-70889 Toolbar Bitmap is not updating correctly
RH-70882 Editing a Macro on a Toolbar Button doesn’t update
RH-70341 Toolbar: Changing the SVG doesn’t update the icon/macro

I get this button when I right click a toolbar and then Edit Toolbar Button

hmm, I cannot seem to repeat that issue. Does it also happen if your scaling is 100%?
I tried setting my scaling to 175% but that didn’t trigger it.

It looks alright at 100 %


Okay, I see this now too, I was testing on a larger toolbar. It seems that it creates a scrollbar even when not needed when windows scaling is active.
RH-72161 Edit Toolbar popup creates scrollbars at scaled display settings

Is it normal that I cannot save a custom button?

Well, here it seems to work, do you get this also when changing the button with a icon from the Rhino library?

I can set the macro and it is saved in the default library. Unfortunately after closing and opening Rhino WIP 8 the macro is not in my toolbar anymore. It is still available in the library.

Hi Martin - I see this is broken - I think there is a bug on the pile for this but if not I will add one - thanks.
I’ve added a comment here -
RH-71936 Toobar: ease the process of making a new button


1 Like