Shortcut stops working in new session


#1

I made a small python script which I initiate with a keyboard shortcut “Y”. It works fine, but after closing the Rhino session and reopening it again the shortcut will not work anymore, the y appears as an unrecognized command. Opening the command customizing UI and selecting the"Y" (or replacing it with another shortcut) and saving it will make it work again, but only for the current session.
I am running version 5.4.2.

04


(John Brock) #7

I don’t do any python scripting so I just used a big macro and made a keyboard short cut for it. It works just fine and survives a Quit-Restart.

Does the Python script perhaps need to be loaded before you call it?


#8

No John, I tried that. I am pretty much convinced it is the shortcut itself, otherwise I don’t think it would appear in the command line. And as I said, opening the customizing UI and retyping the shortcut and save it makes it work again and runs the script ok.


(John Brock) #9

Sorry, I’m not clear.
Were you able to repeat the problem or after saving it a second time, now it works and survives a Quit/Restart?


#10

I was able to repeat the problem. After saving the shortcut it only works until quitting Rhino, but it did not survive a restart. Mind you, by opening the customizing panel it seems to be there (see picture), but it just does not work.


(John Brock) #13

Can you please send us your Rhino plist file?
The developer wants to see if we can repeat the problem.
Here’s a link to help you find it:
https://wiki.mcneel.com/rhino/mac/resetprefs


#14

Plist sent - see PM


#15

FWIW John, none of the shortcuts seem to work, including the default ones. Never noticed that before, I really never felt the need to use them until now.


(John Brock) #16

One of the Mac developers is going to give me some help with trying to duplicate this next week. Hopefully we can find something and get it fixed.