Shelling not executed


#1

Why do not you run the shelling (0.5) of the upper surface of this volume? Check please.
(Rhino 5 SR8 64bit)
shelling failed.3dm (470.4 KB)


(Pascal Golay) #2

Hi Davide- the thing shells here but the result is not closed. I can see several problems with the original object, and some of these are likely to come from building at a loose tolerance. I would build this from the beginning at .001, and certainly not more than .01 tolerance and see how that works out - I would say .05 is too large.

-Pascal


#3

I do not know where the problem lies. When I run him shelling on the upper surface, using various tolerance settings, Rhino crashes, as if the calculation would never end;
perhaps the volume originally built by me will have some problem! I do not know …


#4

Maybe it’s the fault of the fillet (see enlargement). Check Pascal, thank you.


(Pascal Golay) #5

That is a ugly fillet- it ends up being where the naked edge is in the offset here, but I would not spend too much time troubleshooting this object and result, as it seems to have been built at .05 tolerance and that is just too loose.

-Pascal


#6

I explode, delete all fillets, untrim all edges, set tolerance to 0.01, deleted the caps, closed the surfaces, ran boolean difference, filleted the edges at 2.0 and tried to shell, and it failed again.


(Pascal Golay) #7

Bugs added for the ugly BlendEdge and open Shelling- thanks.

http://mcneel.myjetbrains.com/youtrack/issue/RH-24660
http://mcneel.myjetbrains.com/youtrack/issue/RH-24659

-Pascal