ShapeDriver tab disappeas after restart of Rhino 6


the ShapeDriver tab keeps disappearing on each restart of Rhino 6. After dragging ShapeDiverForGrasshopper.gha from C:\ProgramData\ShapeDiver\bin (where the installer is automatically putting it) onto the Grasshopper canvas the ShapeDriver tab stays but only until Rhino 6 gets closed. I have to keeping dragging above each time Rhino 6 gets start.
Is this a bug or am I missing out some additional settings required to make it working properly?

Grasshopper tabs after dragging ShapeDiverForGrasshopper.gha onto the canvas:

Grasshopper tabs after restarting Rhino 6:

  • Rhinoceros Version 6 SR24 (6.24.20079.23341, 03/19/2020)
  • Grasshopper Version Thursday, 19 March 2020 23:34, Build 1.0.0007
  • ShapeDiver (installer) 1.6, 2019-11-26


Enabling following settings should resolve the issue. Let me know if that worked for you.

Additionally, you should not have to drag the gha file from C:\ProgramData\ShapeDiver\bin, to the canvas. There is a .ghlink file in the Components folder that links to it, so if you drag it on the canvas it will move it from the bin folder to the components folder and will probably break some references.

What happens if you just use the installer and open Grasshopper without moving anything? Do you not see the plugin in the tabs? Even if you open Grasshopper with admin permissions?

Hi @pavol,

the Memory Load… option was already enabled before. So this unfortunately doesn’ t fix it.

Hi @mathieu1,

I guess it has something to do with the C:\Users\...\AppData\Roaming\Grasshopper\Libraries\ShapeDiver.ghlink file.
Interestingly the file C:\ProgramData\ShapeDiver\bin\ShapeDiverForGrasshopper.gha does not get moved to C:\Users\...\AppData\Roaming\Grasshopper\Libraries after dragging it onto the Grasshopper canvas (which would be normal behavior as far as I experienced).


ShapeDriver 1.5 is working fine on my steup.
With ShapeDriver 1.6 there was an Rhino console output on initial startup after having it (re)installed:

Am Laden Rhino-Renderer, Version 1.50, Mar 19 2020, 23:54:52
Testing C:\ProgramData\ShapeDiver\bin\\ShapeDiverGltfExporter.rhp (and 21 other assemblies) for compatibility...
Compatibility test succeeded in 6.16s
Befehl: Grasshopper
An error occured during GHA assembly loading:
  Path: C:\ProgramData\ShapeDiver\bin\ShapeDiverSquid.gha
The GHA file is either damaged or has been made with
a newer version of .NET than Grasshopper itself.
You can try toggling the "Memory Load" option in the
GrasshopperDeveloperSettings command window, it might help.

With ShapeDriver 1.5 there is no error message even with Memory Load… option disabled (assuming the version does not inlcude ShapeDiverSquid.gha):


after uninstalling ShapeDriver 1.5 and (re)installing 1.6 it suddenly works with the latest verison as well.
Still strange behavior since I already installed and uninstalled v1.6 a couple of times before creating this post.
Only after installing, running and uninstalling v1.5 and afterwards installing v1.6 again, everthings works correctly.
Anyway, the issue is solved for me.

1 Like