ShapeDiverTextFIleInput - "File can not be read" error on Mac

I encounter problems running script on Mac that worked flawlessly on Windows. I downloaded the last available ShapeDiver (version 1.7.0 even though the food4rhino page describes it as 1.7.1). I saw similar problems happening to multiple people, however my colleague, also having Mac, does not suffer from this error.

I tried both local files or files publicly available, but I have no success with either of them.

What am I missing? I am quite new to Mac so there may be some obvious “firewall” blocking the reading of the files which I am not aware.

About the local file access problem:
Likely this has to do with the permissions given to Rhino for accessing your Documents folder. Please check out this help page (look for Files and Folders).

About the import from a URL:
Please post the error which the component throws.

Hello, thank you for the suggestion, for the local files it was apparently set for “Documents folder” already. The files were in this folder and still it did not work. I changed the settings to “Full Disc Access” and restarted Rhino, but still no success:

For the import from web URL I get similar message, even though the file should be accessible to anyone with the link:

Thank you for any help,
Vladimir