Shapediver: strange problem with Perlin Noise/units?


I have a strange problem with a script I’m uploading to Shapediver.

It is a custom-made floor tile pattern, and utilises the Perlin Noise block.
Four different colors are distributed by the Perlin Noise to the tiles.

The script works in Rhino/Grasshopper:

However, when uploaded to Shapediver, the scripts distributes Color 4 to all tiles…

Strangely enough, when I download the export file from Shapediver, it does work correctly…

I have the impression it has something to do with units/tolerances. When I set the parameter “Pattern Scale” to 0 in my Rhino/GH, I indeed get color 4 across board. The “Pattern Scale” parameter is scaled to about 1e-6 at some point to make it work with Perlin Noise. I tried changing tolerances, but to no avail…

Could someone help me with this?

Thanks a lot,

Sebastiaan Leenknegt19_013 RS Patterns (21.1 KB)

The problem is not so strange after all. You need to input the geometry in a tree in order to render it in different materials, more on that in this video tutorial.

Also in your case, the model would hit the 64 parts per output limit and further optimisation was needed to make it work. Have a look:

19_013 RS Patterns (41.5 KB)

I also recommend to watch our tutorial series, you can quickly learn how to build optimal definitions for web.

Hi Pavol,

thanks for your quick reply! Guess I should do the tutorials before starting to tinker… :slight_smile:

It works now: