ShapeDiver embedded model won't load in the website

Hi ShapeDiver team,

I am having a ShapeDiver model embedded in our website using a ticket for direct embedding method.
I updated the model today and use the new ticket to embed again.
But somehow that the website cannot find the model anymore.
I also notice that it always generates a new ticket when i access “edit the model”, even i don’t edit anything yet.
Is that any other possible reasons that causes the model cannot be found/loaded into the website?


Shaun Wu

You need to allow domains for the model you uploaded and also use the ticket from the same model for embedding. Go to model edit page, check the box to add global domains and apply settings.


Hi @pavol

I have followed your instructions and use the new ticket to embed the model.
However, the same errors still not resolved.


We allow port 8080 for local testing.

I don’t know what is the correct domain for Heroku but you can find it out in the browser network tab. This Documentation article explains how, see section about Wix. Makes sure you use only the domain part without the “https://” bit.

Hi @pavol,

I have followed your instructions again, but the same problem still not solved.
Have double checked the x-shapediver-origin

Add the domains to the shapediver model without “https://”

The localhost 8080 also not working, same error message appeared.

The embedding works, I can see the embedded model on your web site without any errors. Try hard reloading the page and clearing the browser cache.

@pavol oh! it didn’t work a few hours ago, perhaps takes sometime to process it.
Thanks a lot!