Shapediver DXF Export Setting $INSUNITS

Hello,

I working with a fabricator that uses an online DXF quoting software, which doesn’t have the ability to set units. It reads the $insunits of the DXF and assumes it is MM when we want the file to be Inches. I confirmed this by opening the DXF (exported from Shapediver), changing the $INSUNITS from 4 to 1, saving and reuploading - the online program recognized the units as Inches.

The client specifically wants the file exported for them in inches, and the file to be 100% ready on download.

Is there anyway to set the INSUNITS when exporting? Or another way to flag the DXF units as inches? So that the file is ready and correct on export.

Other than scaling the drawing in GH to be correct as MM on export, or opening the file and resaving it with updated units, or manually editing the text file after download …

Weird nuance. Thanks for the help!

When exporting DXF files, the units are set to the unit system of the Rhino document. You can use the Tolerance Settings component of the ShapeDiver plugin to define some properties of the Rhino document on the servers, including the unit system. Please read carefully the documentation of the component, and in particular note that the inputs of the components need to be set directly as internalized values and not through connected parameters.
I just uploaded a file including this component with the unit system set to 8 (the code for Inches in Rhino):

Once uploaded to ShapeDiver, exporting a DXF file results in the correct value for $INSUNITS (1 = Inches in AutoCAD):
image

Let me now if that solves your issue.

Thank you! Yes that was it!