Shadows poor quality with no accuracy - SOLVED by PASCAL and HOLO

Hi Antonio - did you try playing with the camera based clipping bubble size?

-Pascal

YEs… i have try everything possible.

Clipping Bubble always off.

I’d try turning it on, and seeing what difference it makes if you make a relatively tight bubble around the camera area.

-Pascal

Weird…

I did not made any changes on shadows Menu… but i have rotate pan view mode some times… and now it result in better intersection shadows.

have a look

Just a guess but it could be that rotating the view changes the depth of the scene from the current camera. I’d still try the clipping bubble to see if it does anything useful.

-Pascal

Can you explain me what is the exact purpose of Clipping Bubble Camera Based is?

is this the explanaition:
"Also take care of the “Camera Based Clipping Bubble” slider. Your model
should fit in that bubble. Do not adjust it unnecessary larger than your
model. If the shadow settings do not get you better results, it might
help if you upload your model so it can be further inspected."
by Clement - Rhino 5 - Rendered View - no Shadows

Hi Antonio- yeah- that is what I had in mind. But here, it seems that it’s not working completely as advertised in that objects outside the bubble do affect the accuracy of the shadows. e.g. make a box, and copy it far away, like 100 or 200 x the size of the box. If only the first box is in view, the existence, or not, of the second box does affect the accuracy of the shadow cast by the first box, even if the bubble is pretty tight around the box. I’ll dig some more.

-Pascal

So… if i understand…
It helps if we addjut Bubble Clipping Shadows and put the Bubble at the same size of the model.

Well i try it for a while and lets see what happen.
(you dont know how much time i spend on tweaking shadows to get similiar results as sketchup) = with straight edges and high accuracy intersections on shadows with solids.

Also if you don’t use the GroundPlane but has a custom plane for the ground then turn off it’s casting shadow abilities.

Improvements

high res (1920x1080) x2scale (-viewcapturetofile)
this image is by far some intended quality i was talking about. Finally!!! :smile:

So i have been report this question about the shadows and thanks a lot to PASCAL for solving all my problems.
At least for this file… (further i will test it “bubble clipping” on some 800MB complex File.

I work a lot with capturefile to send images to photoshop and work them to presentations. They are more fast then tunning all on a Software Render… But till this day i was not able to out perform a good shadows quality. THANK GOD…or better… THANKS PASCAL

Looks good! Great.

(and, incidentally, solved by developer Jeff laSor, not me - I’m just the messenger…)

Phew.

-Pascal

But still no 100% accuracy on shadows intersections.

And “HOLO” i am using a non ground plane. Instead i made a planar surf to zero Z-coordinate with no CAST SHADOWS…
It keep result in non 100% accuracy.

A bit OT: but here is a paper on OpenGL shadows issues:
http://www.opengl-tutorial.org/intermediate-tutorials/tutorial-16-shadow-mapping/

1 Like

So… about the lights. Correct me if i`m wrong.

It is better to use a Directional Light or a Sun Shadow???

AFAIK the Sun is just a directional light so it should be the same.

1 Like

Well… THANKS A LOT for all your precious helps.
I will keep working and see what happen as time pass on workflow

Cheers
:slight_smile:

1 Like

Well i have to say that it will depend on different kind of situations.
File size… Complex polysurfaces…and so one.
But as far i could understand with HOLO user, rhino shadows are a bit complicated than other softwares.

You have to read this article to understand why is it so complicated.
http://www.opengl-tutorial.org/intermediate-tutorials/tutorial-16-shadow-mapping/

Nevertheless, we Rhino users just want perfect shadows, that work like other softwares (for me like sketchup), and work as fast and great accuracy no matter what. Specially if you work on rhino with “viewcapturetofile” PNG high resolutions output.

I think we need to wait for a new Rhino version with better tunning/tweaking shadows and OpenGL support as on CPU multiple core better improvement.

… but have you try to test the CLIPPING BUBBLE SHADOWS under the View displays modes options?
Try to fit the bubble to your project… I think i achieve better results when i made changes on that option. The bubble dont need to be huge or to small. Just the same size as your project… or in other way… Try to insert your project inside the bubble. And always draw your projects near the (0,0,0) coordinates.

Sorry i can not help better, but honestly i am on testing to. One think that i noticed is, no matter how i start, it will depend to much on the complexity of your model

cheers

@Architex @Holo @pascal

Hi there! Stumbled across this when looking for the same issue - trying to emulate SketchUp shadows in Rhino…

Acknowledge this was in 2015… so I am querying if this ever improved? Just in my mind it sounds bonkers to have to go to this length to get a flat, basic shadow.

The above didn’t work for me anyway, any improved or saved preset of display mode that one can use?

Thanks

Hi.
Well in Rhino 6 you have the new Display mode called Arctic. It is an White Ambient Oclusion and you can turn surface edges on. The shadows remain not flat as sketchup but its a nice ambient in rhino.
I think you can give a try on shadows option. there is a option shadow “soft edge quality”.
I have testing all around but its impossible to have the same result as sketchup. I remmeber some one, some day explain here in forum that it is because how rhino calculates all light sources and projections. In fact in real life there is no hard shadow edges. Remember it. But i agree. For sketches, Sketchup shadow is a nice feature
In the end of the day, you can install “vray” or “thea render”. Both can achieve great B&W images and then you always can overlay with vector lines in illustrator or photoshop.
You can give a start try with my displays “white and white shadows” and give a tweeking as you like.
If you find better results or similar to sketchup give us a note please.

03 - White.ini (10.4 KB) 04 - White Shadow.ini (10.4 KB)

Cheers

I know that it’s necromancy, but…
I wonder if that is a trilinear-style smoothing issue at the edge of a shadow map.