Shadows missing from rendered display mode

The black is just the built geometry itself, but it is not casting shadows over the “ground”…

Hi Nicole - OK, yes, thanks, I see it in this view - well, your video support is on that great here - I am not sure if the 4000 is expected to work for shadows but you could try boosting the memory available to shadows in the options.


Thanks… Thanks… tried that but no change. I tried all the sliders in fact… Only modifying the “bubble” some shadows appear… but not sure if thatás the correct way to do it

I’m having this problem. I believe I checked evertything suggested above. Noticing that spotlight and point light display cast shadows whereas rectangular light does not- neither does linear light.

Can anybody get cast shadows on this model? Thanks.!AmEW-HsXOJs0qy9h5JvCa4zs8G9h

Hi Michael - in Rendered mode that is actually expected as far as I know - these lights are not supported in the openGL preview - but a full render should work…

Thanks, Pascal.

Hello All, I am actually having problems with the shadows also in rendering mode. I have done all the things you have suggested but it´s still not working. I would truly appreciate if anyone could help me as I´m desperated. Thanks a lot!!
Any suggestions???

Hello - are the materials all set to use self illumination? It looks like they might be.


Thank you very much for the instant response I really appreciate this.

How can I check this?? The problem is that when I render it the shadows
show up, but in rendered mode they don´t that is what I don´t understand.
Also its a bit weird because sometimes they show up when I play with the
Camera based Clipping Buble but only in a fixed view,and in certain
objects, if I move the view a bit then the shadows dissapear.

Hello - I’ll just guess for the moment that the scene is too large - if you hide all but a relatively small part of the scene do shadows come back?


Still doesn´t work…

Hello - I guess we should see the file - if you make a new file with a box and a plane, do you get shadows? Is the Rendered mode set at defaults?

If a new file at defaults shows shadows please post a small, if possible, file that does not show shadows, to, we’ll take a look.


Can you try something simple first…just to see if shadows are completely broken…

  1. Start Rhino

  2. Draw a box

  3. In the Perspective view, set it to Rendered.

  4. What do you see? Screenshot please.

  5. Go to the Render Tab and UNCHECK Skylight (see image).

  6. Now what do you see in the Prespective view?


Did this ever get completely resolved? I’m trying to work on a sundial ring prototype for a client and I’d like to demonstrate the effect. I have the entire ring set to not self illuminated and I’ve boosted the memory used for shadows. Both Sun and skylight are off, per images below.

Here’s what I get in in the rendered screen…

Here’s this…

And this…

Hello - what happens if you make the ring material non-reflective?


Hi All,
For me there is no “Use accelerated hardware mode” option at all… I went into the OpenGL folder in preferences but the page only shows “Appearance Settings” and “Video Hardware & Driver Settings.” Any advice?

Thanks in advance!

The accelerated hardware setting was a V4 and V5 thing. It’s not exposed in V6.

I do see that @gary2’s GeForce drivers are quite old.
Since shadows are an OpenGL think, I’d be updating the drivers.

A post was split to a new topic: Shadows missing