Shadows lost


#1

My rhino 6 file suddenly lost its shadows in rendered mode. Shadows, however are checkmarked under the shadow settings of the rendered display mode. Sun and skylight are both on.

Any way to resolve this?


(Pascal Golay) #2

Hi Arman - is the scene very large? Architectural, for instance?
@Arman_Fissette, I mean large in extents - model units -not on disk.

Does it work in a new simple file?

-Pascal


#3

not that big, 150MB.

In other files it works. Copying some parts from the file concerned to a new one had shadows working.


#4

also the ground plane moved down without me touching it…Maybe they’re related


#5

Another thing I notice, is that when I zoom in closely to objects, they get “clipped” by some non-existing clipping plane that’s parallel with the viewing window.


#6

the file is reasonably small in extents: 12m. max.


#7

Seems like the file has some bugs in it, related to viewing (shadows, ground plane, clipping).

Is there a way to take the whole model, with all settings (Bongo, materials, etc) and export it, to a fresh file in order to lose the bugs? I don’t want to copy/paste a 150MB file if there’s another, more secure way…


(Pascal Golay) #8

Hi Arman - can you send us the file? SaveSmall, zip, and upload here, please: www.rhino3d.com/upload.

thanks,

-Pascal


#9

The file is under confidentiality agreement. How does that work?


(Pascal Golay) #10

Hi Arman - the upload site and tech@mcneel.com are both private - only McNeel people will see the files.
@Arman_Fissette - there are two very large surfaces in the file - Zoom Extents to see them. If you delete these it should work better.

-Pascal


#11

thanks, that worked.

I believe those two large surfaces were generated by Rhino while I was doing a Boolean on an object that contained a lot of isoparms. Generating the Boolean, as well as the meshing took a very long time. After that, things got buggy, so I suspect it was due to that.