Shadows from corners?

Hi there!

I’m trying to create a display mode giving relatively sharp objects as well as some ambient occlusion, something that could closely resemble a clay render made with V-Ray. The result I’m getting is decent, but I’m seeing a lot of corners that do not produce shadows, see the bottom left of this building:

The two surfaces are not intersected but one does go clearly though the other:

Is there some settings that could minimize this? This would be very practical for diagramming and shadow study purposes.

That has to do with the size of the scene and the shadow settings for the display mode. AO shadows are also created with the skylight in Rhino and can be displayed in addition to directional shadows from lights in the scene. I’m not sure what version of Rhino you are using but Rhino 6 is much better at AO shadows and there is a mode called Arctic that you may like here as well. Post a model and I can take a look. If you have a sample image of what you are after that would be good to see as well.

@rheinason, This looks like the self-shadowing offset going off the rails… It can get worse depending on the overall distances involved in the scene…

I would go into the Shadows settings for Rendered mode and adjust the “Self-shadowing Artifacts” slider as far to the left as you can without having self-shadowing artifacts showing up.