Shaded view surface edges offset

So in shaded view the surface edges display an offset from the actual surface, as seen in the image. This happened after scaling (for 3d print). Any way of fixing this? I assume it has to deal with some kind of display accuracy? Model is close to origin and units are set to mm (as the model).

What is the absolute precision, and how big are the objects?

DocumentProperties > Mesh What are the settings?

Choosing smooth and slower solved it, thanks!

However, it becomes slower :wink:

Is there another way of solving it? It works fine when it’s in meters, just scaled larger. Where do I change absolute precision?

Edit: Absolute tolerance is set to 0.001 and the objects are around 10x100mm

Absolute precision is set in DocumentProperties > Units.

Absolute precision of 0.001 is reasonable for objects 10x100. You might try 0.01 I don’t think absolute precision should affect graphics speed. You could experiment with the Detailed controls in Mesh > Custom.