Shade command old bug


#1

Hi @jeff,

when i am in a Shaded Viewport, and run the non permanent _Shade command, there are various options to Show the grid, axes, curves, isocurves etc. The option to show/hide curves does not work here, it toggles the Z-Axis instead which has been a bug since early V5 days.

To repeat, run _Shade and set it to _DisplayMode=Shaded and _DrawCurves=Yes. Press Enter to exit the non permanent _Shade display. Create some curves in the document. Then Run _Shade and set _DrawCurves=No. In my case, the curves stay visible but a Z-Axis is shown. Once i use _Enter and run _Shade again, the curves are hidden as they should. If i set _DrawCurves=Yes the Z-Axis gets hidden.

I do not understand why there is a Z-Axis involved at all. The viewport was in permanent Shaded Display mode and when i enabled _Shade which it is set to _DisplayMode=Shaded.
.

c.


#2

Could we not maybe cull the old Shade command? With the view mode properties panel it’s pretty redundant…well even more redundant than it was by V3?


#3

Well i´m using the non permanent _Shade command for one thing only, get a quick clean view of the model without curves and isocurves. Mostly when i am in Shaded or Rendered permanent Display mode. If it would be gone i would have to set up a display mode which does not show curves and isocurves for every other display mode. The Display Tab and Display Mode properties are still not scriptable so there is really a reason for me to stick with this command as long as there is no alternative.

c.