Severe heat up and lag with even tiny files

Severe heat up and lag while using Rhino

I am facing an issue of heat up and lag in Rhino.

This is happening with files that hardly have any geometry. Even if I create a new file with just one rectangular surface, my system heats up to 95 degrees celsius. I have to force close Rhino restart my laptop in order to get back to normal. After an hour or so, this happens again.

I have 3-4 folders open and just one notepad file with 3-4 sentences. No other software are running in the background. My laptop is on flight mode. My antivirus is disabled.

My system specs are

Intel core i7-8th gen processor-8750H, 2.20 GHz
230 GB SSD, Samsung EVO 970, nvme. Rhino is installed on this drive.
1 TB Hard drive
4GB Nvidia GeForce GTX 1050Ti graphics card

Check the video here. It’s a 56 mb file.

https://www.dropbox.com/s/6x126jmvcd8a7ud/VID_20210316_201300.mp4?dl=0

The flicker is happening automatically. I am not touching the laptop at all.

My windows are up to date, my drivers are up to date.
My Rhino version is 7.4.21067.13001.

Please run the Rhino SystemInfo command and post the results.
How many monitors are you running?
How are they connected?
What resolution?

Thanks

1 Like

I don’t have any monitor attached. I am using my laptop. It has only one screen. The resolution is 1920x1080

Here’s the system info output. I removed the hash text.

Rhino 7 SR4 2021-3-8 (Rhino 7, 7.4.21067.13001, Git hash:master @ ------I removed this text)
License type: Corporate, build 2021-03-08
License details: Stand-Alone

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [88% battery remaining]

Hybrid graphics configuration.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-18-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 2-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.72
> Integrated accelerated graphics device with 1 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-23-2021
Driver Version: 27.21.14.6172
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino WIP\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino7.rhp “Karamba3DLicense”
C:\Users\JUGGERNAUT_BOLTZ\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SpeckleRhino2 (8dd5f30b-a13d-4a24-abdc-3e05c8c87143)\SpeckleConnectorRhino.rhp “SpeckleRhino2” 2.0.5.0
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot10RhinoPlugin (ccedd9da-83b9-429a-aec5-8ec90b85fe67)\1.0.0.0\KeyShot10RhinoPlugin\Rhino 5.0\KeyShot10RhinoPlugin.rhp “KeyShot10RhinoPlugin” 1.0.0.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.4.21067.13001
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21067.13001
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21067.13001
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21067.13001
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

Hello - please disable all of these plug-ins:
Karamba
SpeckleRhino2
KeyShot10RhinoPlugin
V-Ray for Rhino

in Options > Plug-ins page and then close and re-open Rhino - does that behave any differently?

-Pascal

1 Like

I have disabled the following plugins

SpeckleRhino2
KeyShot10RhinoPlugin
V-Ray for Rhino

I didn’t disable Karamba as it’s only a license check plugin. Moreover, I didn’t want to risk getting an error in Grasshopper launch as it is used within Grasshopper.

So far everything is normal. I’ll post back once I face an issue. Thanks for the tip!