Setpts to align to 0 on z axis not working for blocks

Is there a solution out there? Can’t get my blocks to work with setpts.
Thank you.

Hello - Align in an elevation view should work.


1 Like

Thank you Pascal. WIll try. And is there a way to lock top view to draw on the z axis at 0? When I click my “project” box on the bottom toolbar, it draws like 7FT above the z axis…?

Hello - if ‘Planar’ is set, click that to disable (un-bold) it.


It wasn’t on. I tried again toggling it. Nothing. Still drawing above z axis when in plan view.

Hello - I can only guess that the active plane in Top is not what you think it is. Note Project only applies to object snaps, which is does not appear that you are using.


How would I set the active plane to z 0?

Hello - CPlane command -

CPlane World Top


Hi Pascal, I did the cplane>world>top but Im still drawing above the cplane. Any ideas?

After cplane top as suggested, I tried a line again, and again, it’s drawing above the cplane z 0. Even setpts doesn’t seem to work. ???

Hi Peter - in Top, type in

Line w0,0,0

and then click someplace to end the line.
What does that look like in an elevation view?


It looks like a flat line still showing above the cplane 0 in front view. But in front view, if i do “line” and 0,0, it snaps the line to 0 in the cplane where it should be.

Right so your front plane is some non-standard plane, not World Front.

TryCPlane World Front in that view.


Thank you. I believe this solved the issue! So how might I prevent this problem from repeating on future drawings?

Now to bring all elements back to 0, I use setpts > set z and align to world, and then for “location for points” type 0,0. Is that correct approach?

BTW, I learned that blocks do not get pulled into 0 with this approach. I have to manually edit each block to bring it to 0. Not a big deal.

Thank you again Pascal!