SetOneDaySun Command Issues

rhino
rendering
render
sun
rhinosun

#1

Basically, Rhino’s render display and renders of light and shadows are no longer “working” for me.
So I had success recording a preliminary sun study using the SetOneDaySun command, and the image I’ve attached is one of the frames. I was able to get light and shadow to come through the first couple of times I ran the operation, with the addition of a honeycomb shading system.
All of a sudden, it doesn’t want to work anymore?

I’ve checked the shadow box in display properties, checked off “Use accelerated hardware modes” in the OpenGL tab, no additional light sources besides the sun. I have also tried manually getting the light and shadow to show in Rendered view by inputting time/day and making sure that the CPlane is oriented correctly. When I render the scene it comes out as a black screen. Any ideas as to why?

Thanks in advance!


(Brian James) #2

Hi Stephanie,

Would it be possible for you to share the file publicly here or email it to Tech@McNeel.com referencing this forum post? If the file is too large to email you can upload it to us using http://www.rhino3d.com/upload

I’m also curious if the issue is just in the Rendered display mode or also when you run the Render command? Please also point out what the honeycomb shading system is within the model.


#3

Thank you for the quick response -

I have sent the file to tech@mcneel.com referencing this post.
The issue is in both Rendered display mode and also in the Render command, although the two do not necessarily seem to be having the same issue? Renders come out as black screens whereas the Render display mode will show the model at least. The “honeycomb shading system” is a general blanket term, the file has the shading components on a separate layer and is a three-dimensional array of double-curved units. The .zip file I uploaded has the Rhino model and a couple of frames of the previous sun study tests with the shading component.

Maybe there is an easier way to model the shading system? Any work flows that will achieve what I’m looking for?


(Brian James) #4

Hi Stephanie,

There are a couple things off the bat that weren’t working well. The first is that the shade geometry made up 3700 separate polysurfaces which was weighing down the shadow calculation from the sun in both the Rendered viewport and the Rendering itself. It works here but very slowly. To solve that issue and make the viewport rotation much faster…

  • Select all the shade geometry
  • Run the command ExtractRenderMesh
  • Immediately run the Join command to join the separate meshes into one mesh object.
  • Move this one mesh to another layer and hide your shade geometry polysurfaces… save a copy of the file without them in it too if you like.

After this is done, I think you’ll find you can get the Rhino Render sun animation to work well again. The problem then is that Rhino Render does not have global illumination so you won’t get very realistic lighting on the interior. For this type of scene I’d go with a render plugin like Vray or anything else that you are familiar with that has GI and preferably irradiance mapping to remove shadow noise. This is a feature you’ll find in “biased” renderers. Vray excels here which is why I suggest it. Here’s a sample of your scene using Vray 2 which is all I have here to test, they’re on v3 now. The only settings I changed from defaults were to…

  • enable the Rhino sun in the Rhino Sun panel
  • use the Vray Sky texture in the Skylight and Background channels of the Environment section of the Vray Options.
  • Turn on the Physical camera in the Vray Camera Options.