Set Area Parameter

Hi everyone,

I have created a new project parameter. It is an area parameter but looks like I can’t set its value using Grasshopper. Can anybody help?

There are a few ways this can go wrong. Please take a look at the definition below and see if it helps.

Thanks for answering @Japhy,

I have tried to set custom area parameters but somehow I always got the result as 0. Now I understand why. Looks like Grasshopper actualy converts its units to Revit units(I think).

For instance:
I have created a new project parameter named “Custom_Area” and set its type to Area. Then I created a simple floor with 168 m2 area.

Got this floor in Grasshopper, turned it into brep, deconstructed that brep, selected top face and found the area using Area component.

  • Area value that I get from Grasshopper is in square centimeters.
  • Revit units for Area is square meters

That is why I though I have to divide the number that I get from Grasshopper to 10000 to get the value in square meters. When I did that and set the Custom_Area parameter, value is set as 0.0017 m2.

That’s when I realized I don’t have to do any conversions because RIR does it for me. This is the result when I don’t do any conversions.

I apologize for wasting your time with such a simple question but I didn’t know this nuance.:sweat_smile:

no problem.

FYI, You can deconstruct a parameter coming out of revit and see the units and some additional info.