Service Release and SR candidate

It looks like the evaluation version which is on the Rhino website is actually the SR candidate…

This is the name of the file which I download rh50_en-us_5.13.60913.21340.exe

It might be also because I’ve installed the SR candidate once and then tried to revert back to the regular SR… I’ve uninstalled Rhino, cleaned the registry from everything suspicious, installed it again from this file… yet still when I’m referencing the RhinoCommon.dll it’s 5.1.30000.17 (while as far as I know the SR was 5.1.30000.16).

I’m not sure why you are calling the rh50_en-us_5.13.60913.21340 release a release candidate.
These two links refer to the same 2016-09-13 version.

In the process of releasing a new SR, one or more SR RC are published. When one of these is stable it just becomes the SR. That is, any final service release is just a release candidate that was promoted.

Currently, the last SR13 RC (I think it was RC5) was stable and promoted to final SR. Because of an issue with expired digital signatures, however, a new version was released on September 13th (60913). Since this one won’t be SR14 I guess it had to be promoted to final SR right away…

What I’m really talking about is that the computer with SR 12 which is right next to me says that it’s the most current version… while when you download the evaluation it’s SR 13 (or at least it’s version is 5.13…).

Which means that when I develop on a PC with 5.13.60913.21340 (Installed right from the eval file), people who use the SR12 can’t run the plugins… nor they can update their Rhinos cause the website says it’s up to date (which is not).

That does clarify things.

From time to time there are reports about systems not finding out that there is a new SR available (@brian), but I wouldn’t say that it is a wide-spread problem.

Two things come to mind as a way forward:

  • The user will get the message that the plug-in was written for a newer version and will then hopefully manually check for newer versions. Or at least start asking questions about this.
  • You can link to an earlier DLL - say from SR10 - when building your plug-in (of course not if there is something that you need in the newer version) so that it will install on all versions from SR10 onwards. Here’s @menno saying what he uses: Plugin Error: Rhino not up-to-date

…are you sure when you upgrade to SR13, the RhinoCommon.dll is going to be 5.1.30000.17 rather than …16 ?

I’m not sure how to check for the version number of that dll. If you have 2 versions and one is called 16, the other 17, I would expect the one called 17 to be the newer version.

The current public release on our web site is SR13. It includes a small number of fixes for:

  • Bug fixes to support Flamingo nXt 5
  • Expired evaluations allow loading core McNeel plug-ins
  • A few other minor fixes

We decided not to push this update automatically because, for the vast majority of our users, there’s no reason to get it.

Aha! I had wondered why my automatic update was not catching it. I even did the manual check and the McNeel website returned “Your installation is the newest available.

I thought it was weird that people kept mentioning a new SR that only I was not allowed to have. Mystery solved.

@MateuszZwierzycki, 5.1.30000.16 is SR12. 5.1.30000.17 is SR13. I agree with @wim that it’s a good idea to target an earlier version like SR9/10, unless you specifically need something that was introduced in a later service release. I can help if you need a hand tracking down these older versions of rhinocommon.

Hi @will
My problem is that in the meantime I’ve switched to a new laptop and don’t have any way to install an older release. That’s actually a source of all kinds of dependency pains… it would be really good to have access to them on some official website (like here or here in the archives section)

I can help if you need a hand tracking down these older versions of rhinocommon.

Please do :slight_smile:

Just a note @brian,
The latest panelling tools by @rajaa on Food for Rhino only works with SR13 because the automatic update is not running i can’t run it.

I realise i can download the latest SR by putting in the email and Rhino Key but as i work for a large architecture office all the licences are in the zoo. So not so easy for me of my colleagues to run this plugin-unless IT manually update our machines i think.

I don’t know of any other plug-ins just yet but there maybe in the future if this is the last SR.

Have you tried running the latest paneling tools?
On F4R it says that the latest version is from 2016-01-20. I downloaded it and checked the dates in the package and they are all from January 20th or before.

It is only the updated version of SR13 that doesn’t trigger the automatic update - the previous version of SR13 does.

Of course, that doesn’t mean you IT department doesn’t have to do something to roll out SR13 but it shouldn’t be that the latest version isn’t pushed to users that is causing a problem here.

Yeah it the latest Panelling tools, the download say’s January 20, 2016 but the upload date of the file is September 14, 2016 So i guess something may have changed.

The latest version of PT is what bought up the error saying it can’t load, Seems i am only on SR12 but have Automatic updates set some don’t know how i missed the Previous Version of SR13.

I will speak to IT about rolling out SR13 too.

Yes, I think that’s a mistake. I have suggested that we release PanelingTools compiled against SR12; I’m not sure if @rajaa plans to do that.

@mattgaydon yes, I plan to release a new version this week.

1 Like

@mattgaydon A new release of PT was published today. It works with Rhino 5 SR12.