SelLayer (GetLayer dialog) - double click select layer?


#1

In Windows Rhino, in SelLayer - and others that use the same dialog including rs.GetLayer() - double-clicking on a layer name selects it and closes the dialog. On Mac Rhino, double clicking does not work, you still have to hit the “Select” button. Would be nice if this worked as in Windows, seems to be a pretty standard action for Mac too…

Thanks, --Mitch


(Dan Belcher) #2

Looks like this bug: MR-869. How much is it impeding workflow, in your opinion? (You know, relative to all the other bugs on the list :wink:?) Should I give this a priority bump?

We’ve tended to down-prioritize these "papercut " bugs relative to more major ones, but if it’s really getting in the way…


#3

Nope, I was just letting you know, didn’t see that it was already logged. It’s certainly not critical. I’m currently testing my Mac script collection before I release the first version, and reporting any issues I find.

Thanks, --Mitch


(Dan Belcher) #4

Ok. Thanks Mitch!


#5

hi, Dan,
I also have a problem with SelLayer in rhino for Mac.
When I want to select all the objects in the same layer, only click the layer name is worked. But in windows, we can select one object, then rhino will select the layer name in the dialog automatically. This problem is impeding my workflow very much. As if the layer system is very complex, it is hard to find the right layer name in the dialog, but in windows, I can select the object in the same layer easily.


#6


(Dan Belcher) #7

Hi James1-

Sorry, I’m afraid I’m not understanding the problem. Can you please provide an example file and simple steps to illustrate the actual behavior and the desired behavior?

-Dan