Selecting dot freezes beta


#1

Not sure if the grouping has anything to do with it, but the most recent beta is freezing when I try to select a grouped text dots, and also when I try to ctrl-shift-select one dot from the group. Thx.

bug.3dm (193.2 KB)


Rhino 6 SR0 2016-12-6 (Public Build, 6.0.16341.12271, Git hash:master @ 876bc66685a133f2c9a1c5db09da3c44398d15ec)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

GeForce GTX 1080/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 369.56)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 10-9-2016
Driver Version: 21.21.13.6956
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript” n/a
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a


(Pascal Golay) #2

Hi Hannes - so far OK here - did you test with the exported dots file, or only in the original file?

-Pascal


#3

I tried it both ways.


#4

I can confirm this. although it does not happen all the time.
possibly somehow dependent on the display mode?!

Rhino 6 SR0 2016-12-6 (Public Build, 6.0.16341.12271, Git hash:master @ 876bc66685a133f2c9a1c5db09da3c44398d15ec)

Windows 7 SP1 (Physical RAM: 48Gb)

GeForce GTX TITAN X/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 376.19)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 12-1-2016
Driver Version: 21.21.13.7619
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 12 GB

C:\Program Files\Rhino WIP\Plug-ins\SolidTools.rhp “SolidTools” n/a
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript” n/a
C:\Program Files\Rhino WIP\Plug-ins\RPC.rhp “RPC” n/a
C:\Program Files\Rhino WIP\Plug-ins\AnimationTools.rhp “AnimationTools” n/a
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a


(Pascal Golay) #5

It is certainly slow in Arctic but not frozen…( which just seems wrong, somehow).
Rendered slows down as well but neither seems related to grouping so far…

Still poking…

@hanscad - can you tell if this is related to the current display mode in your case? Doyou get the same behavior in all display modes?

-Pascal


#6

It does not seem to be related to display mode.


(Pascal Golay) #7

Hi Hans - thanks - I cannot reproduce this here in your file nor in any others so far. I’m at a loss … @stevebaer - do you have an idea? Looks like at least two users, @hanscad & @dk2079 are seeing this:

-Pascal


#8

Actually I just tested again and found that I’m not seeing this behavior today, after yesterday’s new version of the beta. I had a freeze from this yesterday on the same file, so it must have gotten fixed in the mix.


(Pascal Golay) #9

Just the answer I was hoping for - thanks for the update!

-Pascal


#10

Sorry I spoke too soon, I did get another freeze.


(Steve Baer) #11

Does this freeze only occur when the properties panel is open? If the layers dialog is open instead, do you still see the freeze?


#12

I’m having trouble duplicating the error again right now, but I always work with both the layer and properties panels open.


#13

still freezing with the last WIP.

I have properties and layers open all the time

I can select them successfully if I disable “text” in display, and select via right click in layer tree, and delete them. (they sometimes appear by them self after bool operations “!”)